0
$\begingroup$

I have a curve (which is a loop) that I am trying to manipulate in edit mode. When I use proportional editing with connected mode, a certain part of the curve is not affected. It only seems to happen between two vertices. On one side they act as expected and on the other side they stay where they are.

I tried converting the curve to a mesh, deleting and the re-adding the vertices that caused the problem, and then converting back to a curve. The same problem occured, but between two different vertices.

If I switch the proportional editing to enabled mode, everything works properly, but I want to know why curves behave this way with connected mode. I assume it's because the curve "ends" somewhere, so even though the loop is closed blender doesn't consider the vertices on the other side connected. I'm unsure though so if anyone knows why this happens or where I could read about it, it would be appreciated.

The verticies that seem to cause the problem: The verticies that seem to cause the problem

What happens when I drag the selected vertex up. The left of the curve from point 1 moves, but to the right of point 2 is uneffected: What happens when I drag the selected vertex up. The left of the curve from point 1 moves, but to the right of point 2 is uneffected:

How it looks when I use enabled mode for the proportional editing: How it looks when I use just enabled mode for the proportional editing

$\endgroup$
  • $\begingroup$ could you please share your file? $\endgroup$ – moonboots Jun 26 at 5:56
1
$\begingroup$

If it's a Bezier curve, your proportional edit circle has to encompass the handles of the point as well as the point to move it. GL Ten four rubber ducky. Over and out.

It looks like Blender calculates "connected" from the point and traces it back down the original curve, and if you connect 2 ends of the curve with F key (make segment), Blender doesn't read that as a new path, so to speak. I'm not sure how to fix that though. Hope this makes sense.

$\endgroup$
  • $\begingroup$ Thanks, that's what I kind of thought was going on, like I said I can just use Enabled mode and I get the desired effect. Thanks for the tip on beziers though, I probably would've run into that at some point. $\endgroup$ – Jay Jun 27 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.