1
$\begingroup$

I'm trying an animation in Blender 2.8 (most current release as of 20 Jun 19, although the last couple of releases also do this) which fades up pre-extruded text part way through; I'm running Transparent BSDF and Principled BSDF* nodes through a Mixer node and keyframing the Mixer fac setting to adjust transparency. The text is extruded using the Text Geometry Extrude setting.

Using Eevee, I'm finding that, while the extruded sides of the text are fine, the front face is missing; when viewed from the reverse, the rear face is missing, however Fill Mode is set to Both. The effect is not present in Cycles. (No, I don't want to wait for 160-odd frames to render under Cycles!)

Any ideas, please, if this is a 2.8/Eevee problem and/or if there is a way to get around the difficulty? (Apart from rendering in Cycles, of course).

*Diffuse BSDF also has the same problem.

Blender 2.8 Eevee extruded text

Node Settings

$\endgroup$
  • $\begingroup$ Have you checked the normals on your geometry? Else this just might be an Eevee shortcoming $\endgroup$ – miceterminator Jun 20 at 21:13
  • $\begingroup$ I'll check when this render finishes (at least 6x longer in cycles), but I'm at a loss to see why the normals wouldn't be as you'd hope as this is a really simple 'add text/choose font/extrude/add materials' sequence with no mods. Any chance you can check the process at your end? $\endgroup$ – Quin Benson Jun 20 at 21:29
  • 1
    $\begingroup$ I think extruding in negative normal might cause such a thing, but then the sides would be off as well... Maybe you can upload your file to have other people take a look. blend-exchange.giantcowfilms.com $\endgroup$ – miceterminator Jun 20 at 21:33
  • $\begingroup$ Converted text to mesh, checked normals: they look ok to me, appearing from the centre of invisible faces. Test file link should be in the question now. $\endgroup$ – Quin Benson Jun 21 at 6:37
  • 1
    $\begingroup$ This is a bug related to text and curve objects, a curve with bevel and extrude values has a similar issue with a semi-transparent material in evee. You should submit this as a bug. $\endgroup$ – sambler Jun 25 at 8:39
3
$\begingroup$

To get a transparent material in EVEE we need to set the materials blend mode to alpha blend. When this is enabled the same time as show backface, the alpha of each face gets multiplied and makes the backfaces appear more prominent.

You need to turn off Show Backfaces in the material settings.

material with and without show backfaces

You also get a similar result with show backfaces when the blend mode is set to additive.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.