1
$\begingroup$

I'm doing a render where the lights mostly come from emission materials applied to objects in the scene using cycles, I've tried using ridiculously high samples but the noise is still very obvious. Is there a way to fix this? enter image description here

$\endgroup$
  • 1
    $\begingroup$ Yes, more samples. What is do you mean by ridiculously high samples? Please be specific. $\endgroup$ – cegaton Jun 20 at 5:28
  • $\begingroup$ I've tried 9000 samples, but the results are still similar to a 3000 sample render $\endgroup$ – Starman Jun 20 at 5:44
  • 3
    $\begingroup$ even 3000 is a lot. It looks like it's better to use lights rather than emission shaders, so maybe keep emission at 1 but add some lights to fake the emissions. Also you may find some tricks here: blenderguru.com/articles/7-ways-get-rid-fireflies $\endgroup$ – moonboots Jun 20 at 6:19
  • 1
    $\begingroup$ You could use Branched Path Tracing in Sampling any then increase Mesh Lights samples instead of having to increase samples for everything. Also, try Clamp Direct so that the contribution from any one 'bouce' is more easily cancelled out by other samples (this can smooth the 'noise' quite well). However, as suggested by @moonboots, actual lights are far more efficient than mesh lights - see blender.stackexchange.com/a/89665/29586 $\endgroup$ – Rich Sedman Jun 20 at 15:46
2
$\begingroup$

One option is to use the Denoiser. It is located on the properties bar under Scene. The downside is that by using it you lose detail in the scene. There is a video on Youtube called "Drastically Reduce Rendertime in Blender Cycles New Denoising Feature".

As implied by the title, it also reduces your render times. What I mean by this is that it keeps you from having to do a higher amount of samples, which would increase your render times. The denoiser actually causes each frame to take longer in rendering, but it's way better than trying to increase the sample amount till you get the same result.

$\endgroup$
2
$\begingroup$

As you see on the image, there is more noise where the smaller light sources are. The smaller light sources makes the Cycles ray tracing engine harder to "find" them. When hit, it creates a "firefly". The light source smaller size and brightness level are the two factors what makes the firefly effect worse. Thus need much more rendering samples to dissolve them gradually.

My solution would be: decrease those small light sources brightnesses and faking the similar illuminating effect on the surrounding objects with a larger "invisible" light source.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.