0
$\begingroup$

There is 1 single frame out of a 1500 frame animation where the rendered image doesnt match whats happening in the scene. every other frame looks fine and is working as expected. As a result there is a noticeable stutter due to this 'dodgy' frame. I cant work out for the life of me what is causing it.

The frame just before it looks fine and so is the one after.

450451452

what ive tried:

  • disabled rendering on all objects and re-enabling them one by one to see if there were any overlapping geometry or object.
  • checking the graph editor for any mistakes in the animation of objects.
  • restarting blender multiple times.

So as i was writing the first part i tried to see what was going on 'behind the scenes' and i discovered something which makes me scratch my head till my scalp falls off.

The following renders are from the exact same frames as seen above but from the view of a different camera. ill let the images speak for themselves...

450451452

What you see in frame 451 actually occurs to frame 452 aswell but its flipped vertically. The rectangles are emissive on one side and the backface is set to no material so it cant reflect or absorb any light.

And you'll just have to believe me when i say that everything looks normal in the rendered viewport. I can provide screenshots of the rendered viewport if you want proof.

edit 1- Here is a screenshot which hopefully displays most of the info about the scene. I believe it may be something to do with the way i animated the rectangle to spin. Its just supposed to rotate around the Y-axis at a constant rate. If my guess is correct i would still like to understand why this happens?

screenshot_01

this screenshot should show that there are no modifiers on either light source and that the rendered viewport displays the image correctly. Rendered image is of frame 451

Many many thanks to any replies.

$\endgroup$
  • $\begingroup$ Could you please show the solid view of the scene? Is there a boolean modifier, did you animate the materials somehow? $\endgroup$ – miceterminator Jun 19 at 17:41
  • $\begingroup$ there are no boolean modifiers on any objects within the entire scene. All irrelevant objects have been hidden. the materials are not animated but the object itself is. it is a simple rectangle which rotates continuously. $\endgroup$ – spiffy14k Jun 19 at 20:01
0
$\begingroup$

OK so I saw right with what i said in edit 1. After changing the animation in the graph editor the problem was fixed. Instead of setting the next frame back to 1° after it reaches 360° then repeating it, i made the line continue upward to 720° and onward.

note- the issue arose only when the frame was on 360° and 1°. both the rectangles opposite each needed to be changed. if only one was changed in the graph editor the issue still exists but with only half the "severity".

screenshot

I still dont understand why this would cause such a thing to occur, an explanation as to why this happens would be great. Is this a bug?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.