0
$\begingroup$

I got a new add-on and i installed it, i tried to put the add-on (unzipped) in the add-on folder and when i try to use the add-on in the 3d-view i get this message

Traceback (most recent call last):
  File "/private/var/folders/1z/c63tvc6x6p53dg3mjsbwdrxr0000gn/T/AppTranslocation/F1104D03-005A-40B9-A00A-460ACE763FE0/d/blender.app/Contents/Resources/2.80/scripts/addons/fluent/__init__.py", line 4427, in invoke
    bpy.ops.wm.polydraw('INVOKE_DEFAULT')
  File "/private/var/folders/1z/c63tvc6x6p53dg3mjsbwdrxr0000gn/T/AppTranslocation/F1104D03-005A-40B9-A00A-460ACE763FE0/d/blender.app/Contents/Resources/2.80/scripts/modules/bpy/ops.py", line 198, in __call__
    ret = op_call(self.idname_py(), C_dict, kw, C_exec, C_undo)
RuntimeError: Error: Traceback (most recent call last):
  File "/private/var/folders/1z/c63tvc6x6p53dg3mjsbwdrxr0000gn/T/AppTranslocation/F1104D03-005A-40B9-A00A-460ACE763FE0/d/blender.app/Contents/Resources/2.80/scripts/addons/fluent/__init__.py", line 4136, in invoke
    self.bool_target, self.had_latest_bevel, had_weighted_normals = duplicate_obj(self.original_bool_target)
  File "/private/var/folders/1z/c63tvc6x6p53dg3mjsbwdrxr0000gn/T/AppTranslocation/F1104D03-005A-40B9-A00A-460ACE763FE0/d/blender.app/Contents/Resources/2.80/scripts/addons/fluent/__init__.py", line 1210, in duplicate_obj
    depth = bpy.context.evaluated_depsgraph_get()
AttributeError: 'Context' object has no attribute 'evaluated_depsgraph_get'

location: /private/var/folders/1z/c63tvc6x6p53dg3mjsbwdrxr0000gn/T/AppTranslocation/F1104D03-005A-40B9-A00A-460ACE763FE0/d/blender.app/Contents/Resources/2.80/scripts/modules/bpy/ops.py:198



location: <unknown location>:-1

Anyone know what's the problem?

$\endgroup$
3
  • $\begingroup$ Usually you don't unzip and put the addon anywhere, you just click "install" in the Preferences > Addon panel, unless you have a reason to do it this way? $\endgroup$ – moonboots Jun 19 '19 at 8:18
  • $\begingroup$ I tried both ways, but it gives me the same result, that's why i tried this way $\endgroup$ – Francesco Jun 19 '19 at 8:36
  • 2
    $\begingroup$ Suggest getting a more recent version of 2.8. context.evaluated_depsgraph_get() was added circa last month. It not being defined for version OP is using is error issue above Often for addons it is more appropriate to post an issue to where you obtained it, especially if you paid for it. Feel it is beyond the purpose of this site to fix commercial addons. @moonboots do not think it is an installation issue, the __init__.py and folder location look correct in error message above. If you know what you are doing it is perfectly fine to unzip addon's folder into blender addon folder $\endgroup$ – batFINGER Jun 19 '19 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.