0
$\begingroup$

I'm fairly new to Blender and just wanted to create my own mockup for my designs but I'm having some trouble with these renders. I tried looking for solutions but a lot of examples seemed to be doing something far more complex than what I'm doing.

As the title says, I see some jagged edges these images even when they're not zoomed in. I did an a smooth shade on both squares and used Edge Split after. The square in the far left does not have a modifier while the one on the right has a edge split modifier.

Material-wise, I only used Principled BSDF. The background color is #000 with specular and roughness turned down to 0. While the squares have the default settings.

I understand that it's a raster so pixelation will occur once you start zooming it way too far. But as it is now, I can see the jaggedness even when it's zoomed out. So I was just wondering if there's a way to smoothen these jaggedness.

I would appreciate any help in getting this thing sorted out. Thanks again in advance.

enter image description here enter image description here enter image description here enter image description here

Blender File

Google Drive File

$\endgroup$
  • $\begingroup$ I don't see the same thing when I try to reproduce. Perhaps you could post your file? One thing I can think of might be that you are seeing them in the render output window when viewing at <100%, but if you save the image and view it outside Blender (or press '1' on the render window, to zoom to 100% exactly) then the problem might be gone. $\endgroup$ – edna Jun 19 at 6:49
  • $\begingroup$ Once I finished the render, I opened it in PS and that's where I saw that even on a zoomed out version, it looked jagged. Also, I just added my blender file. Thanks. $\endgroup$ – John Grimes Jun 19 at 21:05
0
$\begingroup$

For future reference, the general preference here is to use Blend Exchange

I think this is a combination of anti-aliasing and the very fine angle and sharp contrast. Which is why even at high quality settings of 300% and 1000 samples in your file, it is still happening.

Here I see it (when zoomed out a bit):

enter image description here

Here I don't (100% scale). Or at least it is hard to detect without my eyes going funny: enter image description here

I would suggest that the filter (anti-aliasing) needs adjusting for this sort of scene. Have you tried playing with the Render/Film/Pixel Filter values? I found that 2.0 looks better and 2.5 is the best. More than that and it starts to get fuzzy.

Quality is sufficient at maybe 64 render samples, which makes testing lot quicker than with the 1000 that you have. Using a Render Region (under Scene/Dimensions panel) to restrict rendering to the bit you are interested in also helps a lot with speed of testing.

This is 300%, 64 samples, pixel filter = 2.5, viewed at 100% (press 1 in render window): enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.