1
$\begingroup$

Whenever I try to install some of the more recent versions of Blender and run them, all I get is a console flash and a blank, gray Blender window before both of them close themselves entirely.

I've been poking around the previous versions and found that I can install and use versions that are based off the .exe installer, but the not .msi installer. This also applied to their .zip equivalents. So far I'm currently running on Blender 2.74 and it works well, but I want to update to version 2.79 so I can be up-to-date with everything.

All of my drivers are up to date, and I did run a debug method from the command panel and got an "Exception Access Violation" error from it. I looked up how to fix it and someone suggested to uninstall the Intel HD Display drive. Mine was Intel UHD Display, but since it worked for that person I figured to give it a go. Anyway, I deleted it, it turned off Night Light mode and kind of messed up the display a bit. I'm doing a system restore to fix it now, but I still don't have any leads on how to get the newer version of Blender working.

Blender v2.74 works well, so it seems that at worst I'd miss out on bug fixes and certain new features.

Any tips?

$\endgroup$
  • 3
    $\begingroup$ Does your computer match requirements? blender.org/download/requirements $\endgroup$ – Martynas Žiemys Jun 18 at 22:32
  • $\begingroup$ @Martin Z I checked my requirements, my computer seems to meet at least the recommended requirements (with the exception of a 3-button mouse), I've checked OpenGL and other features of my computer. Everything is updated as much as they can. I'm not really sure what could be the cause. I ran the program from the Command Prompt and I still get the same error from the debug: EXCEPTION_ACCESS_VIOLATION $\endgroup$ – CScience416 Jun 19 at 4:37
1
$\begingroup$

Original Poster here, I figured out how to fix the problem.

The first thing I did was check exactly what the error was. I found this out by running Blender with the Command Prompt ('cmd' in Windows search, 'cd' into the directory with blender, then ran it) and got the same error, 'EXCEPTION_ACCESS_VIOLATION'

I plugged the error I got into Google, worded as "blender exception access violation" and ran into a different question asked by a user of this site, linked here, and found my solution.

It was the my display driver that needed to be updated. The thing is, I didn't realize this because neither of my driver updating services told me it needed to be updated until today. I use DriverEasy and Intel Driver & Support Assistance. Driver Easy, which I had used to update so many outdated drivers, said that I was completely up to date on my drivers. Intel didn't even say anything was wrong when I first ran the test, so the fact that it decided to tell me things needed to be updated now was something of a mystery, but it doesn't really matter now.

So I both downloaded the installer and the .zip file, and they both work!

So to everyone who was struggling with the same thing I was, and you know your computer should be able to normally run it, check your drivers. Preferably through multiple certified and trusted driver-updating services. Some of them will catch updates that others won't recognize, and some check more drivers than others.

So now my problem has been solved!

$\endgroup$
  • 1
    $\begingroup$ I would recommend not to use automatic driver update utilities. They are a common place for hidden viruses, slow down your computer and are pretty much useless. It's a good idea to always know what drivers are updated, when and to what as well. It might sometimes happen that there are issues in a particular driver update as well in which case something might break after the update so if it's all done automatically without user's knowledge this might make trouble-shooting a lot more difficult. Manual updating might not be a bad idea. $\endgroup$ – Martynas Žiemys Jun 21 at 8:02
  • $\begingroup$ I would agree, you really shouldn't use automatic installers. I'm not sure if I know of any myself, but they do seem rather sketchy. $\endgroup$ – CScience416 Jun 21 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.