20
$\begingroup$

I try to set up an image as background for a basic blender tutorial, but it isn't visible.

This is the image I try to have as background:

enter image description here

$\endgroup$
1
  • $\begingroup$ Using an Image Empty might be a solution... $\endgroup$
    – Samoth
    May 12, 2016 at 7:44

3 Answers 3

36
$\begingroup$

#Background images will only be displayed in:

  1. Camera Prespective view (Numpad 0)
  1. Any of the preset Orthographic views:

Front/Back (Numpad 1 or Crl Numpad 1)

Right /Left (Numpad 3 or Crl Numpad 3)

Top/Bottom (Numpad 7 or Crl Numpad 7)

You're in perspective mode instead of orthographic mode (see the upper left hand corner, it has the abbreviation "persp"). Toggle into orthographic view by pressing numpad 5.

Also, the view information at the top left shows you are in right view, and the background image settings at bottom right show that the image is set to appear only in left view. For that, hit CTRLnumpad 3 to go to left view or change the background image axis to Right to make the background image appear in right view.

The image used must be in a format that Blender supports. For example, a .gif file will not be displayed.

$\endgroup$
3
  • $\begingroup$ It looks like there is an error in the tutorial. $\endgroup$
    – xyz
    Jul 24, 2014 at 8:25
  • $\begingroup$ I'm on a Mac and it's interesting that, with an emulated numpad, Numpad 0 does nothing. Ctrl + Alt + 0 from Ray's answer worked for me, though. $\endgroup$
    – Tin Man
    May 8, 2018 at 14:53
  • $\begingroup$ Background Image also does not appear in Camera View if you are in Local View mode. Toggle back the Global View with NumpadSlash (/) key. $\endgroup$
    – rdllngr
    May 13, 2021 at 12:50
4
$\begingroup$

As answered by Pisurquatre "use Camera Perspective view (Numpad 0)".

Adjust your scene, in viewport, to your liking.
Ctrl+Alt+Numpad 0 to set the camera to this view.
Select in 'View' the 'Lock Camera to View' option.
In the 'Background Images'option, where you have 'Left' selected, instead select 'Camera'.

While in this view, you will be able to adjust the scene AND see the background, too.

$\endgroup$
3
$\begingroup$

That was my problem, but I tried hitting CTRL + numpad 3 or + numpad 1. I just did that then it showed up. But, make sure you are in orthographic view, just hit numpad 5 to toggle between orthographic and perspective view.

$\endgroup$
3
  • $\begingroup$ Lutfi, toggling the numpad-5 key does not turn the display on and off, though depending upon the angle of the view in the viewport, it might be visible in some views in perspective mode, but not others. The numpad-5 key toggles between orthographic and perspective view. To turn the display of the grid on or off, open the properties shelf of the 3D viewport, and in the "display" pane, the item "grid floor" toggles display of the grid on and off. $\endgroup$
    – brasshat
    Sep 15, 2014 at 3:51
  • $\begingroup$ @brasshat He probably means that Numpad-5 toggles the visibility of the background image (because it is only visible in orthographic mode). $\endgroup$
    – stacker
    Sep 15, 2014 at 7:06
  • $\begingroup$ Stacker, you may be right, but in his original answer he explicitly referred to "grid". I attempted to improve what he wrote to reduce the chance of misleading another user . $\endgroup$
    – brasshat
    Sep 15, 2014 at 7:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.