0
$\begingroup$

When i export my object into ue4 it looks awful without auto smooth option I see auto smooth is disabled in unreal engine. Is this possible to enable auto smooth for unreal engine ?

$\endgroup$
2
$\begingroup$

You need to set the Smoothing to Face under Geometry when you export FBX.

enter image description here

$\endgroup$
  • $\begingroup$ not this. İt's only for smoothing. İt doesn't includes auto smooth. Already tried this way $\endgroup$ – trolltime Jun 12 at 20:42
  • $\begingroup$ Then it's something on the import settings in unreal that is missing. $\endgroup$ – Jackdaw Jun 12 at 20:57
  • $\begingroup$ already checked :( still no solution. $\endgroup$ – trolltime Jun 12 at 21:02
  • $\begingroup$ Strange... it works for me every single time. $\endgroup$ – Jackdaw Jun 12 at 21:03
  • $\begingroup$ no no no it works! But it doesnt takes the auto smooth which under Normals tab. $\endgroup$ – trolltime Jun 12 at 21:09
1
$\begingroup$

Ok so i got a couple of solutions for that because i had the same problem, and it was really hard information about it and i want to contribute with more people using blender. So here we go. (this are aproaches for ue4 from diferent people)

Option 1. Generated Smoothing and TSpaces in Blender

In exporting settings in Geometry Tab set Smoothing to >> Face and select Tangent Spaces. Important method for this object must be Ngons free and have clean uv’s. When importing in Unreal Engine 4, select Normal Import Method to >> Import Normals and Tangents. This method let you keep Blender smoothing with calculated normals and hard edges.

Source https://www.multipainkiller-studio.one/dev-tips/export-settings-from-blender-3d-to-unreal-engine-4/

Option 2. Triangulate Before export

.."because of triangulation, different programs does it in a different way. That is why in a program where I bake it looks ok. I triangulate it before export and now it looks fine everywhere".

Source From blender to unreal smoothgroup and shading

Option 3. Mark edges Sharp (not so sure about this one but may work for someone)

Make sure auto smooth is set off, just use normal smooth, and that there are no modifiers on the mesh. Now with sharp edges of your model marked sharp, export the fbx with smoothing set to edge.

Source https://forums.unrealengine.com/development-discussion/content-creation/26005-blender-same-model-but-different-shading-quality

Option 4. With Auto Smooth

Mark Sharp edges with auto smooth enabled in the normals section of the object. Set the smooth angle to be 180°, and when exporting set to "normals only".

Option 5. Importing From Unreal

If you are importing from blender to unreal, and get the degenerate tangent base problem check this

Blender weird shading ..

(cant upload images right now, but i´ll hope to improve the answer later. Sorry if broke any rule, and of course that my english it´s not the best)

$\endgroup$
0
$\begingroup$

I have solved the problem. Click here if you have the same problem. https://forums.unrealengine.com/development-discussion/content-creation/1630503-how-to-enable-auto-smooth-option-for-unreal-engine-need-immediately-help-please

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.