2
$\begingroup$

I have a simple scene with two objects. Each object has scaling keyframes and the animations are different for each object. No modifiers, no armatures, nothing fancy. Just two cubes with some keyframes. When I export to FBX, then re-import the FBX file into Blender, both objects show up, but they both have the keyframes from the first object.

Is there any way to export both objects and have each of them keep their individual keyframes?

If there's some fundamental concept of the FBX format that I don't understand, please let me know.

$\endgroup$
2

1 Answer 1

3
$\begingroup$

According to Bastien Montagne (https://developer.blender.org/T65768):

No bug here, to achieve what you want you need to disable All Actions and NLA Strips options, then you'll get current scene's animation exported properly. Those two options are used to export several animations (usually for a single object), e.g. to export a character and all its animations to a game engine.

So, to export multiple objects with individual animations, do the following:

  1. Click File > Export > FBX (.fbx)
  2. In the Export FBX options, click the Animation button to view animation options
  3. Make sure NLA Strips and All Actions are unchecked

    FBX export options

$\endgroup$
1
  • $\begingroup$ Great answer. I have been frustrated all day by this one. Unchecking the all actions box in animation exports was what i was missing. Thankyou Next thing is to work out how to save different animations as options in the file. $\endgroup$
    – Job Wallis
    Dec 7, 2022 at 10:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .