0
$\begingroup$

I started with one mesh and then separated it later on. When I now try to paint on one, I paint on both.

How can i separate the uv maps or do something else to prevent that?

thank you for all the tips and ideas.enter image description here the head and the body are 2 different objects. enter image description here

I know the map isn't very clean. learning to do that these days.

$\endgroup$
  • $\begingroup$ your 2 UVmaps must not overlay on the Image Texture, otherwise when you'll paint on one part it will also paint on another $\endgroup$ – moonboots Jun 8 at 16:19
  • $\begingroup$ Either pack UV islands on the UV maps so that they don't intersect (comfortable to do when both meshes are part of one object to edit at once or with Mutli-edit option in 2.8) or use 2 separate images $\endgroup$ – Mr Zak Jun 8 at 16:25
  • $\begingroup$ thank you for the help you two :) is there no way to make it its own uvmap? $\endgroup$ – Gaming Mietz Jun 8 at 16:27
  • $\begingroup$ UV map will be shared between meshes of one object. If you separate meshes into different objects you will have different UV maps. Note though that unless you paint on 2 different images this won't necessarily solve the problem - even 2 different objects with different UV maps mapped to one image still can have overlapping on paint as UVs still will be mapped to one image $\endgroup$ – Mr Zak Jun 8 at 17:37
  • $\begingroup$ Are you using the same material on both meshes? $\endgroup$ – Dale Cieslak Jun 8 at 18:22
0
$\begingroup$

Dont give the same material to both meshes, since you are painting on the same image it will affect the other one.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.