0
$\begingroup$

I have two part problem.

First:

I have a circle object, you can see the UV in black.
I selected the middle faces as you can see. I UV unwrapped on the selection.
I am paining those faces(selection), as you can see in the UV editor to the right of image.

BUT! There is the same painting over and over in each face on the entire object? That is an unwanted result.

I only want to paint on the selection in the UV editor. Is it a node setup I did wrong? I can't seem to find this particular circumstance.

Second:

Where are the paints? In the center I have stroke and fill, but they don't seem to do anything. No matter what color I choose, it only paints that white-wash/gray color.

enter image description here

I added this image below (edit): Seems I got the correct Tool-box open. I can paint.

enter image description here

$\endgroup$
3
$\begingroup$

1) You started with a resetted UV mesh (all faces overlapping and occupying all UV space available), then you re-unwrapped part of the mesh. The two unwrapping operation got some overlapping, you can see it if you select all faces. The correct way is to unwrap one time only, then select the faces you want to paint, turn the 3D window into "texture paint" mode, enable the button named "face selection masking for painting" and paint in the 3D window.

2) The stroke/fill controls you tried to use are referred to the grease pencil only. In the UV/image window, you can acces to the paint controls pressing T, to show all tools tabs on the left of the window.

enter image description here

$\endgroup$
  • $\begingroup$ I'll try that right now. Thanks! $\endgroup$ – ejbytes Jun 8 at 9:21
  • $\begingroup$ I see I opened the wrong tools on the wrong window. But still I get multiple images of UV unwrap. I only unwrapped one time. In the UV editor, it shows a single section and in actual object, it's painting where I want it to. But it's also painting in EACH FACE on the rest of the object. Whereas on the UV editor it's painting one painting in the faces I pre-selected. $\endgroup$ – ejbytes Jun 8 at 9:37
  • $\begingroup$ I deleted the UV and tried again. There is something I am missing. It's either the node or the way I am unwrapping. The paint is transferring to the selection + divided among the rest of the object to each face. Very odd. $\endgroup$ – ejbytes Jun 8 at 9:58
  • $\begingroup$ When you reset the UV, every face is assigned to the whole UV space. In the UV editor you may see a square (or rectangle) but in fact there are as many as your model's faces, one overlapping the other. Forget about the node and search more info about UV unwrapping, to get a deeper understanding. $\endgroup$ – josh sanfelici Jun 8 at 12:41
  • $\begingroup$ So, perhaps what I need to do, is NOT select any faces before unwrapping the UV. And then just paint the faces I want to be painted. $\endgroup$ – ejbytes Jun 8 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.