I have a question about animation "best practices": If I want to render my animation at 24 fps, does that mean I also need my animation preview/playback window to run at 24 fps?

Some details: I've created 15 second walk-cycle scene that I want to render at 24 fps. However, when I use the animation playback feature (alt-a), the highest framerate I'm able to achieve is 16 fps. As a result, I've prepared an animation that looks reasonable at 16 fps but is much too fast at 24 fps. Of course, I could rescale my keyframes to compensate for the difference after I've finished the animation, but I'd prefer to see something close to the finished animation the whole time.

Some optimizations I've tried to increase the playback framerate:

  • Sync Mode set to "Frame Dropping"
  • All objects except my character and camera are set to be invisible
  • All subsurf modifiers are set to their lowest level
  • The shading mode is set to "solid" or "wireframe"

Are there additional things I can do to increase the playback framerate? Or do I just need to work around my current 16 fps playback framerate?

  • 3
    $\begingroup$ you do not have to go with the 16 fps. That is just the preview running in the viewport. On a faster computer the viewport would run faster. $\endgroup$ – David Jul 21 '14 at 18:31
  • $\begingroup$ Can you post a blend file? A single character should not be that slow. $\endgroup$ – Mike Pan Jul 21 '14 at 19:12
  • $\begingroup$ Have in mind that viewport playback speed has nothing to do with your final animation playback speed. Once the animation is rendered (through viewport OpenGL, Blender Render, Cycles or any other method) you can then control the playback speed of the output separately. If you render directly to a video file format which is strongly discouraged) the video will have the correct frame rate specified in the render settings $\endgroup$ – Duarte Farrajota Ramos Jul 27 '16 at 1:41
  • $\begingroup$ Check if you have any unapplied modifiers on your objects. $\endgroup$ – Robert Sibek Jun 1 '17 at 6:30

Things you can try to improve viewport performance:

  • Enable VBOs in User Preferences > System. This should speed up drawing of highly complex scenes with lots of geometry.

  • Enable Only Render under the display panel of the 3D viewport. This will hide extra lines and wireframes, which are slow to draw.

  • Disable Double Sided in the object properties editor for high polygon mesh. This is especially helpful on Fermi-level Nvidia cards.

  • Turn off modifiers you don't need in the viewport.

  • Use Simplify in the Scene property editor to globally reduce the complexity of the scene.

  • Make sure you are viewing the scene in Solid mode, it's typically faster than all the other mode, including wireframe.

  • If you are using physics simulations like particles or cloth, make sure they are baked. Otherwise, Blender will try to recalculate them every time you switch frames.

  • $\begingroup$ Thanks! I was able to increase the framerate to 24 fps by using these optimizations and by enabling the "Simplify" checkbox (under Properties->Scene->Simplify). Setting the subdivision and shadow samples to low values in the "Simplify" menu seemed to help quite a bit. $\endgroup$ – Joe Thomas Jul 21 '14 at 19:55
  • $\begingroup$ Thanks! I added it to my answer. I wasn't sure if I should mention that one since you already saidd you manually set the subdiv to a low value. Does your character have hair? $\endgroup$ – Mike Pan Jul 22 '14 at 17:57
  • $\begingroup$ There's no hair on my character, but my computer is a little slow. My scene uses a couple (somewhat complicated) assets that I didn't create, so I adjusted all the subsurf modifiers I could find but I guess I didn't find them all. Now that I know about it, the Simplify tool seems like a much better way to quickly adjust all the subsurf modifiers at once. $\endgroup$ – Joe Thomas Jul 23 '14 at 20:41

This usually happens when I'm animating, but I have found another solution. I animate with my timeline, node editor and my graph editor open all at once, and I noticed that even if frame dropping is enabled that my PC plays the animation in around 10 -12 fps, but by only removing the graph editor, my frames go back to normal speed as it should be. I also noticed that my Blender lags a bit on other navigating controls, too, but that's also fixed by just removing the graph window.

I hope this helps for anyone still having problems after going through all the other answers.

  • $\begingroup$ thanks, closing my graph editor pane fixed the fps for me $\endgroup$ – Andrew Nov 10 '18 at 1:33

You could use the OpenGL renderer (AKA Quick Render) to preview animations. This feature allows you to preview an animation at full speed, but without having to use Cycles/Blender Internal to render a final image. As long as you set up your render settings correctly (choose an appropriate image size, pick a video filename and codec, etc), it will quickly render your viewport to an image sequence or video file. The drawback is that it's not realtime, so it's not interactive. It adds a few steps to your animation workflow, but may be the only option for complex models on slow computers. This is how I have to preview fluid simulations, even on a fast workstation.

enter image description here

In future versions of Blender, we'll see the addition of OpenSubdiv which uses the GPU to render complex models in the viewport. Initial tests look very promising. If you have a GPU, this could end up being your solution.

  • $\begingroup$ The GPU already renders models in the viewport, I think OpenSubdiv is for realtime subserf using several different backends (some for GPU). $\endgroup$ – gandalf3 Jul 21 '14 at 19:00

Go to user preferances and system (User Preferences > System) and go to screencast. Type in 24 (or whatever frame rate you are rendering at) and it should do its best to do that frame rate in the viewport.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.