0
$\begingroup$

I'm trying to animate my golem and to do this I obviously created an armature. The problem is when I link my armature to the golem with the automatic weight settings, it sets the weight to 0 (blue) everywhere.

I think it's because my golem is a little like Rayman in style (I mean he has no real limbs and is just some rock animated together but not touching each other).

I tried to paint it in weight paint mode but it's damn long and kinda frustrating because some parts are really close to each other and I can't really paint where I want exactly.

Here is my golem:

enter image description here

$\endgroup$
  • $\begingroup$ please share your file: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Jun 5 at 14:25
  • $\begingroup$ Ok after checking several options i figured out that if i link my armature object by object it s automatically weight painted , but it's laggy and i wonder why .... Maybe because i ve got to many faces ? $\endgroup$ – iBooface Jun 5 at 14:46
  • $\begingroup$ too hard to know what's your problem if you don't share the object $\endgroup$ – moonboots Jun 5 at 14:47
  • $\begingroup$ Ok here is a link to download my blend file : transfernow.net/files/… the only problem now is that it's laggy and it's impossible to do correct key frames with those lags. $\endgroup$ – iBooface Jun 5 at 15:04
0
$\begingroup$

Make sure your bones have the checkbox marked: DEFORMER in the properties of the bone. Also, when you ctrl+P make sure you choose with "automatic weights". If you see no vertex assigned colors, chances are your armature bones are not setup to deform.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.