I am trying to get simple animations to work, exporting from Blender and importing into my application.

My first attempt was as follows:

  1. Open Blender at factory settings.
  2. Select the default cube and insert a location keyframe.
  3. Select another frame and move the cube.
  4. Insert a second location keyframe.
  5. Export to Collada.

When I open the Collada file using assimp it contains zero animations, even though in Blender the cube animates correctly.

On my next attempt, I inserted a bone armature with a single bone, made it the parent of the cube, and animated the bone instead. Again the animation worked correctly in Blender.

Assimp now lists one animation but both key frames have the position [0, 0, 0]

Does anyone have any suggestions as to how I can get animated (non-skinned) meshes from Blender into Assimp?

My ultimate goal here is to export animated meshes from Blender, process them offline into my own model format, and load them into my SharpDX based graphics engine..

  • 1
    $\begingroup$ I have never used collada but perhaps you can get some tips from this answer. $\endgroup$
    – iKlsR
    Jun 27, 2013 at 13:04
  • $\begingroup$ I could use x format as it is also supported by AssImp, however there seems to be no built in support for it in Blender. Is there a plugin or something I need? $\endgroup$ Jun 27, 2013 at 16:13
  • $\begingroup$ Blender has a .x exporter. Did you read the answer? :) $\endgroup$
    – iKlsR
    Jun 27, 2013 at 16:18
  • $\begingroup$ Sorry, I can't read apparently! I'll give that a go and see how I get on, thanks! $\endgroup$ Jun 27, 2013 at 16:22

1 Answer 1


I tried performing the steps in v2.65 r53189 and it exports the animations correctly. It seems that in v2.66.1 r55078 the Collada export does not output the keyframes correctly.

In the end, I decided to take iKlsR's advice and use x format since it allows me to use the newest version of Blender and is still compatible with AssImp. It also allows me to flip the z and y axes which is a bonus!

  • $\begingroup$ Do try a build from builder.blender.org . Some fixes to animation export where done, perhaps this is now fixed. $\endgroup$
    – jesterKing
    Jun 28, 2013 at 12:41
  • $\begingroup$ Can you reword your question a bit to fit with your answer, just slightly. At the moment both are different. $\endgroup$
    – iKlsR
    Jun 28, 2013 at 17:48
  • $\begingroup$ @iKlsR I don't follow you $\endgroup$ Jun 30, 2013 at 8:31
  • $\begingroup$ @jesterKing I updated yesterday and now the problem is resolved, I can use x or collada format without problems $\endgroup$ Jun 30, 2013 at 8:32
  • $\begingroup$ @gareththegeek in the question, you ask about collada but in the answer, you accept .x. Since you say it now works, you can update the answer. $\endgroup$
    – iKlsR
    Jun 30, 2013 at 13:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .