2
$\begingroup$

I am cleaning up a friend's model and often run into this problem: Often, there are multiple edges of various lengths overlapping along the same line. Below is a visual example:
A picture of three lines/edges of different lengths. ...that overlap to cause: A picture of four vertices in a line, with darker portions representing overlapping edges. ...as opposed to the desired: A picture of four vertices in a line, with a lack of darker portions representing the lack of overlapping edges. I was wondering if there was an easy way to clean up edges like this without manually deleting the offending edges and reconnecting the relevant vertices?

A picture of a Blender gun barrel with an example of overlapping edges.

$\endgroup$
4
  • $\begingroup$ I agree that redoing the mesh might be best. Overlapping edges like this often result from depthless extrusions (right-clicking after applying an extrusion, which doesn't cancel the operation) or repeated boolean operations without cleaning the result (merging vertices, deleting unwanted components). You can kindly remind your friend about these hazards and how to avoid them. $\endgroup$ Commented Jun 3, 2019 at 2:32
  • $\begingroup$ Use dissolve edges... but poorly planned topology (like the mess that you have in front of you) often takes so much more time and effort than doing it over. Look into retopo workflows using shinkwrap and other available tools (... use your favorite search engine for those). You should aim to re-do this using quads and avoid non-planar faces. Topology is not a wrapper to put on top of the object. Topology is your object. $\endgroup$
    – user1853
    Commented Jun 3, 2019 at 2:58
  • $\begingroup$ blender.stackexchange.com/questions/18203/… $\endgroup$
    – user1853
    Commented Jun 3, 2019 at 3:01
  • $\begingroup$ Here's a resource on Topology Guides $\endgroup$
    – user1853
    Commented Jun 3, 2019 at 3:04

3 Answers 3

1
$\begingroup$

Select all the vertices in edit mode and then

v2.79 and below

click spacebar in viewport and type in "Remove Doubles" in the search.

v2.8+

click F3 in viewport and type in "Merge by distance" in the search.

(or)

You can use this software called "Instant Mesh" by wjakob by loading the exported mesh file into this software and get a clean mesh.

link https://github.com/wjakob/instant-meshes

Hope this helps you!

$\endgroup$
2
  • $\begingroup$ The spacebar causes Blender 3.6 to start cycling through the frames? I'm confused. $\endgroup$ Commented Nov 7, 2023 at 23:49
  • 1
    $\begingroup$ for v2.8+ you can try presssing F3 and search for "Merge by distance", space is for playing and pausing animation keyframes. $\endgroup$ Commented Dec 26, 2023 at 9:19
0
$\begingroup$

Check this video, it may help:

https://www.youtube.com/watch?v=s2Df3C3_IYE

$\endgroup$
0
$\begingroup$

In Blender 3.2 what worked for me was in Edit Mode, select the internal overlapping vertices, right click and select option Dissolve.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .