0
$\begingroup$

I am attempting to create a procedural texture to generate land masses, oceans, and clouds on a "planet." I used a series of voronoi and noise textures to generate this image. Planet Image without clouds

When I attempt to add clouds to this texture with a darken and add node (Remove color from area where clouds will be, then add the clouds into the now black areas), the final image becomes pink (the missing texture default color).

enter image description here

When I remove the land texture, or the ocean texture, the clouds are correctly added, and the ocean and land textures work together, but when I use all three I run into the error. Here is the complete node setup (Causes error). enter image description here

While these setups do not cause any errors.

enter image description here enter image description here

Here is the link to the file:

https://www.dropbox.com/s/msvw8v99efdr8c9/Planet_2.blend?dl=0

Any help is appreciated. Thanks.

$\endgroup$
  • 1
    $\begingroup$ your shader tree might be using all the allocated texture memory of your graphics card. did you try rendering using cycles? $\endgroup$ – Samir Rahamtalla Jun 2 at 0:08
  • $\begingroup$ I just tried rending with cycles and it worked. Would you happen to know of a way to get around the graphics card limitation? Could I use the hard drive memory when the graphics card is full? $\endgroup$ – Joey Hayden Jun 2 at 1:11
  • $\begingroup$ It seems to be a limitation of eevee and your GPU, hard disk memory and RAM are not used in processing shaders as far as I know. So you would have to go back to the tree and optimize it for eevee $\endgroup$ – Samir Rahamtalla Jun 2 at 9:51
  • $\begingroup$ Yea, I think that's what I'll do. Thanks for the help :) $\endgroup$ – Joey Hayden Jun 3 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.