2
$\begingroup$

Link to Video

As my model walks along the path it gradually appears to have some degree of offset where the model will depart from the curve and won't rotate the precisely along the path where the curve seems to have 'many' of the black arrows squished together which you can see in edit mode.

On further experimenting I was able to mostly solve the issue by deleting segments and enlarging the curve so there was less arrows and the remainder were more evenly spaced out.

I think part of the problem was that my mesh is fairly small so when I added the path it might have been over too small an area.

Is there a way to force it so that there is an evenly spaced out number of arrows that won't distort my path?

Actually this one might be more obvious.

$\endgroup$
  • $\begingroup$ Could you upload a .blend, its rather hard to tell what is going wrong from the video. $\endgroup$ – GiantCowFilms Jul 18 '14 at 19:48
  • $\begingroup$ I added a .blend where I tried to recreate the problem as best as I could; as I unfortunately saved over it once it seemed like I solved it. In the file you can see how towards the end it diverges a bit. Though previously you could more easily see how it wasn't rotating right with it (or too slowly). $\endgroup$ – RaenirSalazar Jul 18 '14 at 20:14
1
$\begingroup$

The issue is caused by the fact that your origin is not correctly positioned. The animation you applied to your character causes it to move away from its origin, which is why its not working:

enter image description here

To fix this, make your characters walking animation stationary. I would also recommend using the Follow Path Constraint, instead of parenting since it offers more control.

To fix your issue I deleted the movement track in the NLA, and added a key for the correct position to the circle bone.

$\endgroup$
  • 1
    $\begingroup$ The NLA you mean right? I deleted the movement track and it seems to work better, what do you mean though for adding a key for the 'correct position' for the circle/control bone? It seems to move just fine without a key. $\endgroup$ – RaenirSalazar Jul 19 '14 at 15:25
  • $\begingroup$ @RaenirSalazar Yes, Oooops!! $\endgroup$ – GiantCowFilms Jul 19 '14 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.