1
$\begingroup$

Does anyone know, is there any way to subdivide and smooth part of geometry in mesh (in example picture necessary polygons(not all i need) are selected) without effecting other parts and not creating weird shapes.enter image description here

I append my blender file: https://drive.google.com/open?id=1MpRbmkZtTWSo28E2p-hI0R3K8L5u8xAx

$\endgroup$
  • 1
    $\begingroup$ I assume you have tried Subdivide, then adjusted the smoothness slider in the floating panel (bottom left of 3D view after you hit Subdivide) ... $\endgroup$ – edna May 30 '19 at 2:43
  • $\begingroup$ I would say the best is to work the other way around: create an object, smooth it, then sharp the angles you want to be sharp, either with tricks like Crease, Bevel modifier, or with additional edge loops $\endgroup$ – moonboots May 30 '19 at 7:55
  • $\begingroup$ When I adjust smoothing in subdivide panel it starts to increase volume of some selected parts. Maybe I'm doing something wrong? I will append my .blend file. Maybe you'll fix my problem. $\endgroup$ – BitCI Rar May 30 '19 at 13:05
1
$\begingroup$

@edna's comment is actually the answer, in my opinion. I too have had nightmare creations resulting from using a subsurface or multi-res modifier on the whole model, and creasing, preserving sharp edges etc. It's useful when it's useful, but it adds complexity that you might not need, and it can be hard to fix when overused. Using subdivide on a selection and then adjusting the smoothness and other attributes is better for times when you need higher resolution and smoothness only for certain parts. Example:

Rough axe

Say I want this to look a little more like and axe. If I multi-res or subsurface modify the whole thing, I will lose all the blocky shapes, and I'll spend a lot of time editing to try and preserve sharpness. In a worst case scenario, I'll end up with lots of extra geometry that interferes with 3d printing, rendering, or whatever. Plus it's just a pain in a simple case like this. So enter subdivide:

settings

axe puffy

I turn off "ngons" because if it is on I may create geometrically unsound quads. Make a few cuts, add a bit of smoothness, and now the center of the axe has a puffier shape at the top and bottom. Next, the blade:

blade settings

blade smooth

Notice the blade is smooth, but the nearby geometry was allowed to stay simple and pointy. (Real technical terms in use here).

I can proceed like this and make any number of more complex protrusions on an otherwise simple or blocky object. Notice that the parts I left alone remain simple, while other parts have different levels of complexity as required:

axe with several levels of complexity

I hope that helps.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.