1
$\begingroup$

I was trying out the gltf + bin + texture export feature on blender 2.8.

and the model i was exporting had a png eye texture with a transparent background. eye1

with a Principled BSDF shader like this, which worked fine.

node1

but when I exported the model to gltf then reimported it,

the png texture file turned to this:

eye2

and the nodes like this: node2 the alpha line disconnected

so, I was wondering if the gltf format doesn't support transparent textures, or is there something wrong with what I did?

$\endgroup$
1
$\begingroup$

Sorry, this is a known bug, a regression. Issue #425 details it, and a fix is in the works in #506. Sometime in the next few days it should start working again, after that PR gets merged.

Also, even after the missing alpha channel gets fixed, you'll still have to specifically enable blending mode per-material. This is done in the "Settings" panel of an Eevee material, "Blend Mode" should be set to "Alpha Blend".

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.