1
$\begingroup$

No matter what I do, objects are allways visible in render (Cycles). I have tried: Object > Visibility > Show in Renders (off) Object > Visibility > Ray Visibility > Camera (off)

In viewport it works and becomes invisible, but it allways shows up in renders...

Thanks

$\endgroup$
3
$\begingroup$

Filter button;

What you need is hidden there. Blender restricts to one by default, yet you have an option of six.

The Filter button typically sits at the top right of the Outliner, and looks like a kitchen funnel. It will bring up a menu of filter options, and if you mouse over each of the first six, you will know which button does what. You want 'Globally disable in renders' (The sony camera icon).

$\endgroup$
2
  • $\begingroup$ Hi and thanks a lot for your answer. I didn't know the camera icon was hidding in there. Though that is not the problem, as I had already disabled it through the rendering menu.I noticed later that the render was not updating what I did on the viewport. If I moved several objects and hit render, I get the image of the previous state of the scene, as if I hadn't moved anything. The render is not updating my changes... only solution I found was opening a previous version of my work. Still would like to know how to solve this... $\endgroup$ – FilipeG May 29 '19 at 9:18
  • $\begingroup$ I'd recommend providing the scene to look at, are you able to provide a blend file with this problem? $\endgroup$ – Simon Jun 2 '19 at 14:34
1
$\begingroup$

I just struggled with a similar problem, and my mistake was that I had a second mesh in the scene that looked like the object I was trying to hide. I had hidden the second object from the viewport but it was enabled in renders. (I had saved it hidden, in case I needed parts of it later)

The above Q/A helped me find it, and now I know about the filters. (For others: at the top right of the outliner there is an odd little funnel shape that lets you add columns of visibility toggle icons, such as the eyeball that handles the hide-eyeball)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.