0
$\begingroup$

I'm trying to make a fluid with something dissolved into it. It's almost opaque but there are some spots of lower density solute. This is why I can't just use nodes on surface alone--I need to be able to have the opacity partly dependent on thickness.

I figured I could use a Principled Volume node and then put a low roughness, max transmission Principled BSDF node on the surface to give it the reflection and physical surface.

node setup

It didn't work. I was expecting the cube to look a bit like white watercolor paint or milk mixed with water. Instead, I got a black cube.

enter image description here

What is this and how can I fix it?

$\endgroup$
  • $\begingroup$ maybe lower your Principled Volume Density value? $\endgroup$ – moonboots May 28 '19 at 6:36
  • $\begingroup$ @moonboots I need it fairly high so that it is mostly opaque-ish. $\endgroup$ – Bobby G. May 28 '19 at 7:17
  • $\begingroup$ maybe show a picture of what the result should be, if you want something milky perhaps use the Subsurface value? $\endgroup$ – moonboots May 28 '19 at 7:28
0
$\begingroup$

I had the same question, and I believe that this value under Scene Properties>Render>Light Paths>Max Bounces>Volume. When there's a surface material on the volume, it always takes at least one bounce to get into the volume. I believe this defaults to 0.

Screenshot of Blender 2.81 UI, scene render settings, with volume light path max bounces value highlighted

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.