1
$\begingroup$

I imported a model but after i set the materials, these strange artifact appeared and the lighting seems wrong. I tried to recalculate the normals, disable/enable the autosmooth and other things but none of this worked. Someone have any ideas?artifact EDIT: Enabling soft shadows make the artifacts less visible but the problem still persist, moreover I think that this is only diffusing and softening the shadows without removing the issue. soft shadows enabled blender version: 2.8 sorry for my bad english

$\endgroup$
  • $\begingroup$ maybe try Properties > Data > Geometry Data, click Clear Custom Split Normals Data? $\endgroup$ – moonboots May 27 at 15:52
  • $\begingroup$ Thank you for the answer but this didn't work. $\endgroup$ – Parmex May 27 at 16:13
  • $\begingroup$ maybe share a part of your object on blend-exchange.giantcowfilms.com $\endgroup$ – moonboots May 27 at 16:15
  • $\begingroup$ The site continue to give me "error uploading", so i cannot share the object $\endgroup$ – Parmex May 27 at 16:37
  • $\begingroup$ I uploaded the file in a google drive folder: drive.google.com/drive/folders/… $\endgroup$ – Parmex May 27 at 16:44
0
$\begingroup$

I think what you need to enable is the "Soft Shadows" setting under the render settings tab in the shadows dropdown.

Below I have a model with a similar issue with the shadows looking really jagged and bad:

bad shadow

Then, I turn on 'Soft Shadows' (seen on the right), and it looks much better:

good shadow

I am not 100% sure that this is your problem, but it might, be, so I hope it helps.

$\endgroup$
  • $\begingroup$ Thank you for the answer; this reduced the problem but it's still visible,soft shadows don't resolve the issue, simply make it less apparent $\endgroup$ – Parmex May 27 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.