I am using Blender 2.8 Beta on a Mac. Edit: It also happens in Windows

I have created a simple mesh then added an armature. Having added the first bone, I created 5 more by extruding each one from the previous. I then parented the mesh to the armature using automatic weighting.


Regardless of which mode I am in (object, edit, pose) I am only able to select the first bone that I added using the cursor (I am able to select them in the outliner). Looking at the outliner, it would appear that all the subsequent bones are children of that bone, so it seems I can only select the parent.

I have checked that they are all selectable in the outliner and they all should be.

Is this expected behaviour? All of the tutorials I have watched suggest that you should be able to select individual bones in both edit and pose modes.

Have I done something wrong or is there a setting that I'm unaware of? Its very frustrating to have to use the editor to select individual bones.

Here is the .blend file

Thanks for any advice - any more info needed please let me know.

I have the same problem, but only in my computer, if I change to my laptop everything works as it should (with the same armature).

  • $\begingroup$ could you please share your file or at least the armature? $\endgroup$
    – moonboots
    May 27 '19 at 8:50
  • $\begingroup$ Hi @moonboots thanks for your reply, here is an example file cdn.glitch.com/… very grateful for any advice $\endgroup$
    – Nick
    May 27 '19 at 9:29
  • $\begingroup$ it works normal with my 2.8 version, so I'm not sure what's your problem :/ $\endgroup$
    – moonboots
    May 27 '19 at 9:44
  • $\begingroup$ same problem here. To select a bone other than the first, each click on that first bone select other bones in order. Or select with the circle select tool. $\endgroup$
    – Shaun
    May 28 '19 at 19:50
  • 1
    $\begingroup$ Problem solved in last update (May 28, v2.80.72) $\endgroup$
    – Shaun
    May 29 '19 at 15:36

Browse other questions tagged or ask your own question.