6
$\begingroup$

Here's the material property I'm animating: Vector Mapping

No keyframes show up in the graph editor.

I need to change the interpolation mode to linear, but i can't find the keyframes

Edit:

In version 2.81 the same happens.

enter image description here

$\endgroup$
  • $\begingroup$ Is is possible for you to provide the .blend? That would be extremely helpful. $\endgroup$ – Nate_Sycro27 Jan 19 at 23:56
4
+75
$\begingroup$

I have 2 options for you.

1) You need to select the object and the node that you want to animate. It should now be visible in your Graph editor.

2) You need to disable the "Only Selected" icon in the Graph Editor (little icon arrow). See picture enter image description here

$\endgroup$
  • $\begingroup$ Look at the video in the question. The object is selected and no keyframes or curve show $\endgroup$ – user1853 Jan 16 at 18:57
  • $\begingroup$ The Object IS selected but for me it looks like the Diffuse BSDF Node is selected and not the Mapping node. $\endgroup$ – Dan Jan 16 at 20:25
  • 1
    $\begingroup$ Seems to me as the correct answer. Either turn off "Only Selected" button or select the mapping node and the keyframes should be visible in the Graph Editor. $\endgroup$ – Dan Jan 16 at 20:38
  • $\begingroup$ Exaclty, not do you only need to select the object, but you also need to select the "Mapping" node or you can either turn off "Only Selected". $\endgroup$ – DarkSoul Jan 18 at 18:06
  • $\begingroup$ The only way to know for sure is for the person who asked the question to say so. They were last seen in July, last year. I didn't even use stack exchange then, so it is unlikely they will answer. $\endgroup$ – Nate_Sycro27 Jan 19 at 2:01
0
$\begingroup$

I had the similar problem earlier with keyframes not showing in the Action Editor of the Dope Sheet. As I remember I switched the Action Editor to the Dope Sheet and then back again.Action Editor

$\endgroup$
0
$\begingroup$

Hold shift+scroll mouse wheel up to show the keyframes, and shift+scroll down to hide them.

$\endgroup$
  • $\begingroup$ That doesn't hide them. It just moves them up or down. In this case, the keyframes should be shown on the graph, because the picture shows the origin of the graph, the place they normally appear. $\endgroup$ – Nate_Sycro27 Jan 15 at 23:00
0
$\begingroup$

Make sure you select the object with the material which has the keyframes you're trying to edit else they won't show either.

$\endgroup$
  • $\begingroup$ If you watch the video in the question. The object is selected and no keyframes or curve show. $\endgroup$ – user1853 Jan 14 at 16:42
0
$\begingroup$

Ah. I think I may have found the answer. This is 2.81, but the same thing that solves this issue in 2.79 should be the same. MAKE SURE that the editing content being displayed IS set to f-curve, and also make sure that the visibility is turned on.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.