1
$\begingroup$

for the past few days, I've been struggling against artifacts problems with a mesh.

I used the boolean modifier on this following cube :

enter image description here

After applying the "Difference Operation", here is the result :

enter image description here

At first, It looks great, but if I zoom in, you will notice this problem :

enter image description here

I have tried to use the Edge Split modifier, It did nothing.

I also tried to remove doubles, and this happened :

enter image description here

Not only It accentuated the problem, but It also created some holes (as you can see at the bottom left of the picture). My guess is that some faces are overlapping. This problem happens with all the rounded edges. Do you guys have any tip on how to solve this ?

$\endgroup$
  • 1
    $\begingroup$ blender.stackexchange.com/questions/21747/… $\endgroup$ – Duarte Farrajota Ramos May 23 at 12:21
  • 1
    $\begingroup$ You can use a smaller Overlapping Threshold for about 1e-10 to moderate that Overlapping behavior. But it is hard to get rid of it since the algorithm use in blender will generate this restriction. $\endgroup$ – Hikariztw May 23 at 12:42
  • $\begingroup$ Thanks for your answers... Changing the overlapping with a smaller value didn't change anything (Only changes if I increase it), neither by increasing a bit the clip start value. It is not a problem with the view, but with the geometry. I think there is nothing I can do about it... Seems like the Boolean modifier is not viable with cylinders that has a subsurf modifier. $\endgroup$ – Zedce May 23 at 13:02
  • 1
    $\begingroup$ It looks to me like you have overlapping geometry causing z-fighting. Avoid booleans and use proper modeling. $\endgroup$ – cegaton May 23 at 14:43
  • 1
    $\begingroup$ If it is a z-fighting issue, change the view clip start and end to relative close value might help a little bit. $\endgroup$ – Hikariztw May 23 at 15:51
0
$\begingroup$

Solved ! Credit to @Hikariztw and @Duarte Farrajota Ramos for pointing out the answer !

Sadly, I was only tweaking the clip start and not the clip end.

By tweaking BOTH of these options, here is the result :

enter image description here

z-fighting no longer showing up.

Thanks a lot for the help !

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.