1
$\begingroup$

I assigned a material to the character's hair and assigned an ImageTexure. However, the texture is not displayed and the hair becomes black. How can this be solved?

enter image description here

This is the UV used for hair. enter image description here

This is the texture. enter image description here enter image description here

$\endgroup$
  • 1
    $\begingroup$ What are the texture and UV map you were using for? It seems like a hold up area, there must be something disconnect from input $\endgroup$ – Hikariztw May 22 at 14:56
  • $\begingroup$ It's OK for bad English, me too. But please use edit to put your texture screenshot and the UV coordinates map. It is hard to figure out what can be the issue from the little properties panel only. 問題の原因が曖昧のため、texture や UV coordinates mapを edit でアップロードしてください。 $\endgroup$ – Hikariztw May 22 at 15:29
  • 1
    $\begingroup$ Your material and UV maps look okay from what I can see. Textures are working for the other meshes, so your viewport settings are okay. Maybe post your blend (with packed textures) so we can take a look? You could delete everything except the hair if you want don't want to publish your whole model. blend-exchange.giantcowfilms.com $\endgroup$ – edna May 23 at 0:58
  • $\begingroup$ This might be a relative one: Why are objects rendering black even with texture (both cycles and BI)? $\endgroup$ – Hikariztw May 26 at 3:26
  • $\begingroup$ I tried variously but it did not go well. And when I tried to upload the file to blend-exchange.giantcowfilms.com, I could not upload it because of an error. $\endgroup$ – taichi May 26 at 13:21
2
$\begingroup$

Reflected is worked with Specular or Roughness or Clearcoat attributes in principle BSDF. The image texture you assigned is for based color only.

enter image description here

You can use another image texture to tell that hair should be Reflected by changing those attributes.

$\endgroup$
  • $\begingroup$ I'm sorry, my English was not good. I wanted to use "Reflected" in the sense of "displayed". It is my trouble that the texture of BaseColor is not displayed on the viewport. $\endgroup$ – taichi May 22 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.