0
$\begingroup$

When I open an object in Texture Paint mode and set the view to Solid the colors show up as inverted in the 3D view. The colors show correctly in Render or Material view. This is something new as I was Texture Painting this file yesterday and was able to see the right colors with the view set to Solid. enter image description here And if that wasn't bad enough now a new complication has crept up. When I switch to Texture Paint the color portion of the UV Map is switching to that of another object. The outlines however stay the same, just resized to fit over the other UV map. In the 3D view this is only visible with Solid View set. enter image description here enter image description here

PACKED BLEND FILE

Any help sorting this out will be appreciated.

$\endgroup$
  • $\begingroup$ there is no image in your blend file because they are all in your harddrive. To make the things easier, could you please compile them into your blend file? Go in the File menu > External Data > Pack All Into, then share again. $\endgroup$ – moonboots May 22 at 7:52
  • 1
    $\begingroup$ The original Blend file has been replaced by a packed version. $\endgroup$ – Rivercoon May 22 at 8:51
2
$\begingroup$

In the Tools panel > Slots tab, you need to disable the Mask option, and come back to the Canvas Image you're using in your material (called AliBody-Color Diffuse Color)

enter image description here

$\endgroup$
  • $\begingroup$ Thank you. That solves the problem with the inverted colors. $\endgroup$ – Rivercoon May 22 at 19:19
  • $\begingroup$ However when going into Texture Paint the color file in the UV/Image Editor reverts to the one from the last object opened and is shown overlaid by the current grid. It is then is overlaid onto the current object in the 3D View until the file in the UV/Image Editor is manually changed. Leaving Texture Paint and then returning to it repeats the error. $\endgroup$ – Rivercoon May 22 at 19:38
  • $\begingroup$ The correct color file is never shown in Texture Paint with Solid view. $\endgroup$ – Rivercoon May 22 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.