4
$\begingroup$

As the titles says. With a material like this one:

enter image description here

What I get is: In the "material" view, the texture shows up fine, mapped like I want it to be, but in the rendered view, it's rendered in an average of the color of the texture (it's not just black, I tried another texture, a wood one, and the result was a shade of brown averaged from the texture colors). As you can see, though, the preview of the material shows up fine.

Instead, with a material like this one: enter image description here

I get this: In the material view, the texture shows up but it's mapped incorrectly, BUT, in the rendered view, it shows up, but it's mapped incorrectly (obviously).

ALSO: I unwrapped another object (very roughly), applied the same shader as the first one (with coordinates set to UV) and the texture renders fine. What gives? And, it definitely is an average of the color, because I even tried to draw some red stripes on the texture, because I thought that maybe the render was fine and it was some lightning quirk, but nope, non of the stripes showed up in the render.

blend file

$\endgroup$
  • $\begingroup$ Did you actually unwrap the first model? $\endgroup$ – someonewithpc Jul 16 '14 at 16:11
  • $\begingroup$ Yes I did. Admittedly not very very well, but it's good enough for now. Good enough to show texture details and not a single color, at least. $\endgroup$ – Paul Jul 16 '14 at 16:16
  • $\begingroup$ Here the blend file (can't add it to the main) dropbox.com/s/0ak3fsuubr3jv3v/houseupload.blend $\endgroup$ – Paul Jul 16 '14 at 16:43
  • $\begingroup$ @Paul please pack the images in the file otherwise all we get is beautiful pink textures $\endgroup$ – cegaton Jul 16 '14 at 17:00
  • $\begingroup$ Sorry, this is the texture: abload.de/img/brushed-metal-texture7eovs.jpg I know it's not "mapped" to the UV, so it'll look warped, but I'm planning to do that later, once I solve this problem. $\endgroup$ – Paul Jul 16 '14 at 17:09
8
$\begingroup$

Your UV map is disabled.

Enable it in Properties > Object > UV maps by clicking the camera icon next to your UV map:

enter image description here

$\endgroup$
1
$\begingroup$

If you UV unwrapped it, then from the Texture Coordinates node, connect the UV slot to the Vector of the Image Texture. I think that will do the trick. If not, try some of the other slots. I've had this problem a few times and most of the time I can resolve it this way, but not always.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.