I've watched this tutorial about grease pencil in blender 2.8 by Paul Cageggi and I've got the idea to apply over the car a texture of a real car found on internet using the projection painting tecnique.

In Object mode, with the stroke object selected I hit the W key and then I selected the option "convert to mesh",as suggested in this post.

As soon as I have converted the strokes to a mesh,I have switched from layout to texture paint and then I tried to add a texture,as suggested by this tutorial,but surprise,I can't do that. I have no "texture paint" option and I can't add any texture,as you can see below. Can you explain to me why ?


  • $\begingroup$ I can't reproduce the drawing example, but when an object is converted to mesh and needs to be painted, you need to go to edit mode and unwrap the mesh to get UV coordinates to paint with. $\endgroup$ – Craig D Jones May 17 '19 at 12:34
  • $\begingroup$ man,I don't see the "texture paint" option in the drop down menu. It should be there even if I haven't unwrapped the model,or not ? and anyway,after having converted the strokes to mesh,I can't even unwrap the model,because the u key does not work $\endgroup$ – Marietto May 18 '19 at 13:10

I don't think you can directly paint onto the GPencil object that you are converting to mesh. I include a picture here of converting GP to bezier and then to mesh once closed.

Texture paint mode is only available for Mesh objects, so that is why the option doesn't appear.

enter image description here

  • $\begingroup$ Hello. thanks. can u explain to me quickly how to close the bezier curves ? I'm in edit mode now and I have selected two points and I'm trying to close them with the F key,but it does not work. As it does not work the extrude function. $\endgroup$ – Marietto May 21 '19 at 13:39
  • 1
    $\begingroup$ select the curve and press alt-C to close $\endgroup$ – Craig D Jones May 21 '19 at 17:37
  • $\begingroup$ Hello. I tried in a lot of ways,but I'm not able to close the bezier curve. In my situation ALT+C = set 3d cursor (in object mode). Instead in edit mode = toggle cyclic. $\endgroup$ – Marietto May 27 '19 at 9:00
  • $\begingroup$ Maybe try selecting the curve in edit mode and use the search to find the toggle cyclic, or see if it appears in the curve object menu. I’m away from my computer tonight. $\endgroup$ – Craig D Jones May 28 '19 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.