0
$\begingroup$

I am trying to make an animation using soft bodies, but the problem is that they are passing through each other. I have turned on Collision in the physics panel. Thanks. Blend File The Error

$\endgroup$
  • $\begingroup$ it looks like your link doesn't work $\endgroup$ – moonboots May 16 at 15:50
  • $\begingroup$ I have updated it. Please check it out. Thanks. $\endgroup$ – AshKB May 16 at 15:53
0
$\begingroup$

You also need to enable "Rigid body" for each of the objects

$\endgroup$
  • $\begingroup$ Thanks for the answer. I have tried it but the object falls through the floor. Also, I have watched some tutorials and in that, they just enable soft body and collision and it works. $\endgroup$ – AshKB May 16 at 16:15
  • $\begingroup$ Have you given the Floor a Passive Dynamics? $\endgroup$ – Israel Bamidele May 16 at 16:19
  • $\begingroup$ Thanks for the reply.Tried it just now. The same problem persists. I have attached the blend file with the question for reference. $\endgroup$ – AshKB May 16 at 16:22
  • $\begingroup$ Subdivide it a bit and it works, I think it must be just that $\endgroup$ – moonboots May 16 at 16:31
  • $\begingroup$ You mean I should subdivide it while applying rigid body or without rigid body? I have tried it both ways but the problem still persists. $\endgroup$ – AshKB May 16 at 16:51
0
$\begingroup$

Select your object, go in Edit mode, select all and press W > Subdivide, same for the other one, it works, I guess the objects need to be a bit subdivided to interact properly with each others.

$\endgroup$
0
$\begingroup$

Solved. I just needed to check 'Faces' option in 'Soft Body Edges' settings.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.