0
$\begingroup$

im having a new problem today, because blender never ceases to surprise me. im tryingo to do a texture painting, on a model that i created previously, but when i try to paint the color that the painting is showing, and the color shown in the model are different. REALLY different. i have tried changing materials, and removing materials, and textures, but it seems to keep happening, and it is impossible for me to work this way, having to chagne from paint mode to edit mode in order for the color changes to be reflected. In the UV editor, in the image i can see the color it paints, and it is not the color im seeing iin the texture paint, its the extremely whiteish im getting. i also turned off the lights, and no change at all, switched to cycles and set a material and a node to the texture, and the same things happens, im gonna put some screenshots under this to show whats going on. unfortunatelly, in this particular case, i would preffer to not upload the file to the internet, because it is too big and contains the whole design.

Fig 1: This is the previous texture painted,and is showing the color i choose

This is what i see after i paint it in paint mode, (using fill brush)

This is what i see when i tab into edit or object mode and get back to paint, and this is the color that is actually painted in the texture

Any ideas how to fix this? i really need to fix this to be able to keep doing things. any help would de really appretiated.

EDIT: Added brusehs image. enter image description here

$\endgroup$
  • 1
    $\begingroup$ try Blend mode > Mix, and the brush Strength at 1, and disable the strength Enable Tablet Pressure option (button on the right of Strength) $\endgroup$ – moonboots May 16 at 12:46
  • $\begingroup$ We need to see the full settings for your paint fill tool, along with the mix mode settings. $\endgroup$ – Craig D Jones May 16 at 12:50
  • 2
    $\begingroup$ at 0.25 you'll have only 0.25 of your color, also check the other factors: Blend mode and Enable Tablet Pressure option, because it changes the result $\endgroup$ – moonboots May 16 at 13:59
  • 1
    $\begingroup$ yeah, what im trying to achieve is what is in the second image, a slight change in colour, withouth overpainting over the other details, thats why i want like only 25%, because i want like 75% transparency (i hope it makes sense how im explaining it). is there any way to that? $\endgroup$ – Rodrigo May 16 at 14:15
  • 1
    $\begingroup$ maybe first switch to Material Viewport Shading, then paint the whole skin with a 100% strength brush / Mix mode with the color you want, then bring your strength value to 0.25 ans add the colors you want over this skin color, like pink for the cheek etc. You can also switch from Mix mode to Darken. Then use a Soften brush to soften the borders between the colors... Also if you want to quickly load a color, use the pipette (shortcut S), as you're in Material Viewport Shading you'll get the right color (not transformed by shadow or light) $\endgroup$ – moonboots May 16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.