5
$\begingroup$

The title says it all. This is so incredibly, unbearably annoying.

mesh.loop_select doesn't work now... and I can't figure out that they've made it into. Even when reset to default settings I can no longer loop select... so what's up here?

$\endgroup$
1
  • 4
    $\begingroup$ 2.8 works with the right mouse button. Alt+Right Click... $\endgroup$
    – user1853
    May 16, 2019 at 5:07

4 Answers 4

6
$\begingroup$

In Edit > Preference > Input part if you have Emulate 3 Button Mouse in this case the Alt key serves as the third button so the shortcuts do not all work.

Just remove the check mark in the Emulate 3 Button Mouse box.

$\endgroup$
1
  • 1
    $\begingroup$ Thanks. This worked for me. $\endgroup$
    – sotn
    May 31, 2020 at 20:32
3
$\begingroup$

This happens when you have the "emulate 3 Button mouse" active because the hotkey "alt + mouse click" overlaps with the "loop select".

You can either:

  • go to user preferences > input > uncheck emulate 3 button mouse (Duarte solution) or if you need this option active (probably you don't have a 3 button mouse) you can
  • (same place) user preferences > input and in the search box from the right, type "loop select" and change the hotkeys to anyone that suits you.

I don't know if in the newest version of Blender this is solved.

$\endgroup$
1
$\begingroup$

If you mean edge loop then it's just alt+right click, I also found out that if your edges aren't truly connected, Blender won't count them as full edge loops. as you said, SUPER annoying. I'll try to help out if I misinterpreted what you meant.

$\endgroup$
5
  • 1
    $\begingroup$ I'm using alt-left to navigate, since I'm a (former) Maya user. I failed to mention, the loop select seems to work on edges but not on faces for me. Also I can't change the hotkey to anything; it simply won't work at all. I suspected conflicting keys but I've already tried that too. Nothing works. $\endgroup$
    – allen
    May 16, 2019 at 9:39
  • $\begingroup$ I'm not sure what else to try here. I'm usually good at finding what they've changed and adding the appropriate operator. But in this case, I simply can't select a face loop anymore. Not at all, and no clue as to if the operator has changed or not.... $\endgroup$
    – allen
    May 16, 2019 at 9:52
  • $\begingroup$ I just went on Blender's Discord channel and confirmed with others that face-loop select is not working with the latest 2.8 build. So I guess I'll just wait and see if they fix it. Cheers! $\endgroup$
    – allen
    May 16, 2019 at 10:42
  • $\begingroup$ Try one more thing, hit ctrl-tab while in edit mode and go to face selection mode, then, alt-right click on between two faces. and apologies for the answer above, it's alt-right click there as well. $\endgroup$ May 16, 2019 at 16:49
  • 1
    $\begingroup$ The latest build has fixed the issue. Thanks for the help anyway guys, and taking the time to respond. I very much appreciate it. $\endgroup$
    – allen
    May 16, 2019 at 20:14
0
$\begingroup$

In BLender 3.0 they seem to have changed Select Edge Loop to a simple double click of left mouse button. (I'm have 3 Button Mouse Emulation enabled).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.