I'm fairly new to Blender and video editing as a whole. I understand that the playback in Blender's VSE needs to load a video once before playing at full framerate. After playing through a video once, when I return to the beginning, I'm able to play it smoothly at 60fps. However, after around 1000 frames, I get a brief freeze in the video followed by ~24fps playback for the remainder. The audio plays fine at full speed, not freezing with the video and finishing long before it. I've tried this with multiple different clips (flv files recorded with OBS) and the problem is consistent in each clip, though there doesn't seem to be anything wrong with the clips themselves if just played raw through a media player. Does anyone have a fix for this?


1 Answer 1


Seems likely you just run out of the buffer. Because the video frame is actually quite HUGE to computer system, the buffer of the video will be constraint at certain amount for sure to ensure available RAM.

The default setting amount can be find in Setting > System > Memory & Limit: Sequencer Cache Limit

Sequencer Cache Limit

You should tune this amount depend on your RAM size. Yeah, 1024 MB is quite small for general 3D modeling available computer which usually got 16 GB or higher RAM.

  • $\begingroup$ Sure enough, though I'd thought increasing the cache limit to 4GB would've been enough, doubling it to 8GB gave a longer time frame before the inevitable frame drop. That being said, I was planning to edit together a video at least a couple minutes long. Is it possible for me to edit at something like 20fps with the audio still synced, then render in 60fps? $\endgroup$
    – PlasmaBald
    May 16, 2019 at 3:13
  • $\begingroup$ Well, then I have no idea of it. Not used to VSE in Blender (a little bit buggy). You should add more detail in your question, there might be someone else can help you if you clarify it. $\endgroup$
    – HikariTW
    May 16, 2019 at 3:25
  • 1
    $\begingroup$ For further questions unrelated to the original post, please use the ask question box at the top of the page. $\endgroup$
    – user1853
    May 16, 2019 at 5:24
  • $\begingroup$ have you tried using the VSE proxy system to reduce your overhead? $\endgroup$
    – 3pointedit
    Mar 11 at 5:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .