2
$\begingroup$

MY ISSUE: when I export the mesh complete with its armature, only the currently selected action gets exported along in the FBX file.

I've rigged, skinned and animated a character. Each animation is a separate "action", for a total of 4.

The scene includes 3 objects, which means 3 armatures.

The character's body armature is parented (as a "bone") to a rocking chair's armature, so to sync the movement. Each armature is a separate object, but the movement of the character's armature is relative to that of the chair.

I export each of the three meshes (with relative armature) separately. If exported singularly (by unticking the relative option), each action/animation works perfectly, in Unity. If exported altogether, only the currently selected action/animation is exported; and works perfectly in Unity.

I've read threads reporting this issue being caused by keyframes linked to bones that no longer exist. I've checked the "dope sheet" for lines entitled to non-existing bones, but all the keyframes are accounted for.

Is there something I'm overlooking?

This is my 3rd animation attempt, the first two working flawlessly. In the first case it was a tree waving in the wind. All OK. In the second case I added a walking cycle to a pre-existing blend scene. Exported with all the animations without a problem. This time I got the character clean, so I handled all the stages, from rigging to animation.

In Blender everything works great and the animations look good. When I export them, though, only the currently selected one gets exported.

Is there any way to know why all the actions other than the selected one are ignored during exportation? Any log file?

$\endgroup$
  • $\begingroup$ Did you disable anything in the fbx exporter's "Animation" section? $\endgroup$ – FFeller May 14 '19 at 17:11
  • $\begingroup$ @FFeller Nope. All as by default. $\endgroup$ – Steamy_Steve May 15 '19 at 16:46
  • $\begingroup$ Did you try to import back it to Blender to make sure not the Unity import options are wrong? $\endgroup$ – FFeller May 15 '19 at 17:54
  • $\begingroup$ @FFeller Yep, there's only one "action" available in the list, which is the one that was selected at exportation. $\endgroup$ – Steamy_Steve May 17 '19 at 13:09
  • $\begingroup$ Was a solution ever discovered for this? I'm having the same issue. $\endgroup$ – nullReference Apr 3 at 18:52
2
$\begingroup$

When working under the Animation tab, select all with A then when looking at the Action Editor, under Summary, you can see all bones that are being moved and or rotated for the selected action.

Here you need to make sure all names and bones are valid (Ie. nothing with red lines under it when you click the arrow beside the bone name). One this is complete you can open the Modeling tab and will want to select all meshes (using Shift + LMB/RMB) and use Ctrl + A and apply the scale.

Then within the Outliner, you will want to expand the armature, then Animation, then NLA Tracks, then expand each Action Stash. Then expand the Pose tab, and with selecting the bottom-most mesh you want to export, and Shift + LMB the armature, it will select every mesh and anything within the Armature in the outliner.

Finally, go to File->Export->FBX, under Include go Selected Objects then Shift + LMB Armature, Mesh, and Other.

Under Transform, change Forward to Z Forward. Disable Add Leaf Bones under Armature, and lastly, disable Force Start/End Keying under Bake Animation (which should be checked).

With this, you can move to the desired output folder and click Export FBX.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.