Again, blender is extraordinarily unintuitive, I have no idea how anything is done or why the developers chose to set up anything the way they did, I'm just going to take a whack at explaining this and hope it comes across clear because that's the only thing I can do.

When I key-frame an animation for a bone in blender, then go to the graph editor, then open the otherwise hidden tab on the left by dragging the "+" symbol, it makes several sub-tabs accessible. One of those is the "modifiers" tab. Among one of the options in the modifiers tab is "noise."

When you click on this noise modifier, it does what you'd expect by adding noise to whatever key-frame sequence you have selected in the main graph editor window.

However, I want this noise to change over time. I want the noise to start out with a low amplitude, then grow to a big fluctuating amplitude.

But, when I right click on the parameters in the noise modifier tab, there is no keyframing option.

So how do I accomplish this?


1 Answer 1


To open the Graph Editor right panel, press N.

It looks like you can’t keyframe the F-curve modifiers values (I don’t know why though), but you can influence the course of the modifiers through the time by several methods:

  • As explained here: "You can create empty, set Noise on it, and copy location from it using constraint. So you can animate constraint’s influence, this is the way to key noise’s influence." Maybe it can suit your needs?

  • You can also open the Restrict Frame Range menu of your Noise modifier and play with its start and end values.

  • You can add an Envelope modifier after your Noise, add as many Control Points as you want and play with them to restrict or expand the effect of the Noise.

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .