0
$\begingroup$

I am using Cycles Render and v2.79. I have an object that is partly transparent and when I set the background to transparent (check transparent under Film) the object has no alpha and is rendered with the background (which is white). The rest of the background is transparent and edges that touch the background have variable transparency.

enter image description here

The two circled objects have the same material which is just a principled shader...

enter image description here

Why does this happen and what should I do to fix it? How to do I get the object to render with alpha?

Thanks for any help.

$\endgroup$
1
$\begingroup$

You can use 2.80 or a recent daily build of 2.79 from builder bot: https://builder.blender.org

Here in the film section you can find additional Transparent Glass option:

enter image description here

But if you don't need refraction, you can try Transparent shader instead of Principled transmission.

Or even in recent builds you can use Alpha value in Principled BSDF:

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.