0
$\begingroup$

If I set the render image dimensions to something too large, then when Eevee gets to rendering the first sample, my screen would black out (backlight still on) and then some seconds later Windows would come back and the Blender window would be white. Checking on task manager, Blender's CPU and GPU usage is at 0% and killing the process is the only way to close Blender. Rendering at a smaller image dimension would proceed as usual (mark that in both cases, the VRAM usage is 100% and some system RAM is used as well.

My config:

  • A10-9600P
  • AMD Radeon R5 Graphics
  • AMD Radeon R7 M340 (which was R8 M445DX before a driver update and Blender sees it in Preferences as 'AMD Radeon R5 Graphics')

VRAM: 512MB Blender 2.8 in all the betas I've tried (Q4 2018 - Now) Scene has volumetrics btw

$\endgroup$
  • 1
    $\begingroup$ 512MB is quite a small amount of VRAM to fit your scene and rendered pixels into. This should not be a surprise. I don't see how this problem can be solved by an answer. $\endgroup$ – Martin Z May 13 at 5:20
  • $\begingroup$ Then what's holding my GPU back from using system RAM? My GPU can use up to 4GB of my system RAM as spillover. $\endgroup$ – iBlueDust May 13 at 5:28
  • $\begingroup$ I wouldn't count on it being possible to use RAM instead of VRAM, but maybe I don't know something. Well, it should not crash like that so you could try reporting this as a bug. However, I think a reasonable thing to do would be to upgrade the hardware to something more appropriate and better matching your needs. $\endgroup$ – Martin Z May 13 at 5:51
1
$\begingroup$

From the Limitations page:

Memory Management

As of now Eevee uses OpenGL, and GPU Memory management is done by the OpenGL driver. In theory, only the needed textures and meshes (now referred as “the resources”) for a single draw call (i.e. one object) needs to fit into the GPU memory.

In practice, using too much GPU memory can make the GPU driver crash, freeze, or kill the application. So be careful of what you ask.

It is possible the EEVEE crashed on the VRAM size, if the single draw call need more RAM than the VRAM actually have.

The sharing from system main RAM is kind of storage, while the shader program (OpenGL) need all the resources stored in your GPU RAM to run that program. Like a warehouse(RAM) and workshop(VRAM), you can't directly use the thing stored in warehouse.

And the 512 MB is quite small for nowayday OpenGL application, Blender may not focus on these light weight devices support for now, nor does full feature OpenGL. So try to limit some setting in EEVEE to make it fit to 512MB.

$\endgroup$
  • $\begingroup$ Yea i ended up having to reduce polygons and sending the project to my friend who has 4GB instead of 512MB. But thanks anyway. I hope blender can sort out render bounds in Eevee since Eevee would still render the whole frame first then crop unlike cycles. $\endgroup$ – iBlueDust May 14 at 6:04
  • $\begingroup$ @iBlueDust That will be a very difficult solution since the render pipeline is way different from cycles. And that is not how EEVEE suppose to do, still a good feature if any. $\endgroup$ – Hikariztw May 14 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.