Scale not centred on selection or origin. I have an image showing this. Am I just not aware of a feature that is for some reason active or is this an issue? In the image the bottom half is showing the actual objects origin which is centred. And the top portion is showing how it is scaling. the object is symmetrical in all direction. Apart from seeing the offset of the scaled selection the actual scale indicator, thin black line with across on the end, is consistent with the selection. I just don't know why that scale centre point is where it is.

as described above I just created a movie but I can't seem to upload it. It's only 11mb. Link here. Sorry.

Movie demonstrating the issue more clearly 1

Movie demonstrating the issue more clearly 2. Extra info and interesting outcome - read comments for more.

  • 3
    $\begingroup$ Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and use the tools from this site to upload images so that they are displayed as part of your question. See How to upload an image to a post? $\endgroup$ – user1853 May 12 '19 at 5:36
  • 2
    $\begingroup$ As the screenshots are cropped no settings of the tools you use are visible as part of the question. As for the link in the end of the question - I dind't get almost anything related to this question from it except for what happens on 0.17-0.22. It's quite possible that object is not radially symmetrical or scaling is not happening to bounding box but to something else. Try to select one circular edge loop at a time and running LoopTools > Circle (not sure where is it in 2.8 now) to make object actually symmetrical. $\endgroup$ – Mr Zak May 14 '19 at 19:49
  • $\begingroup$ Just adding the link here as well to help with clarity incase you didn't see that change above. As said I couldn't figure out how to embed it directly. burramundi.com/public_access/… $\endgroup$ – EkDor May 16 '19 at 0:40
  • $\begingroup$ Added another movie: burramundi.com/public_access/… $\endgroup$ – EkDor May 16 '19 at 2:37
  • $\begingroup$ In regards to the second movie it seems I have found what's causing the issue but I have no idea why. In the centre where I have opened up my tris to become quads. The centre vertex looks like the issue even when I don't select it. Also looking at some of the origin centre tests, it looks like the vertex is in error, perhaps it's calculated at a different translation to where it is shown onscreen (it renders fine). But there is actually something odd going on with translate despite an earlier comment where I thought it wasn't. two overlapping issues with it. Can be seen in the movie. $\endgroup$ – EkDor May 16 '19 at 2:44

Your scale is always relative to the location of the 3D cursor when you have it set as the pivot point. Place your cursor in the center of the selected section and try again. Type [SHIFT-S] and use "Cursor to Selected". Make sure your pivot point is set to 3D cursor. Then the selected vertexes will scale as you are expecting them to.enter image description here

  • $\begingroup$ Thanks for the reply. I normally have the cursor visibility turned off and was sure I left it centred on world zero. Just checked and it is still set to zero position. That's would not appear to be causing it. Playing with that object to shake it loose. Duplicated, Edited, shopped it back down to it's quarter etc. It insists on being off-centred. I'll make a movie to demonstrate more clearly since the image doesn't show this very clearly. $\endgroup$ – EkDor May 13 '19 at 6:06
  • $\begingroup$ Sorry I forgot to mention that I tried what you said about moving to selection. The cursor did move but the centre of the selection when scaling did not. I forgot to to demonstrate that in the video but it acted exactly the same as seen. Thanks for your help. P.S. About to attach the movie if it will let me. $\endgroup$ – EkDor May 13 '19 at 6:37
  • $\begingroup$ EkDor - well hmmm... I posted another answer while waiting for your video. It's below. I will check back later. $\endgroup$ – atomkey May 14 '19 at 19:38
  • $\begingroup$ Also - just to make certain - you are in orthographic view right? Perspective view can throw things off because it considers distance. To toggle use '5' on the keypad. $\endgroup$ – atomkey May 14 '19 at 19:52
  • $\begingroup$ Yes it's orthographic. I've worked in 3D apps since the late 90's (infini-d first main app) so I can tell by eye what mode it's in. $\endgroup$ – EkDor May 16 '19 at 0:17

menu tab in blender 2.8

I don't know if this is exactly what your problem is, but I also had trouble scaling an object around the point of origin because it kept scaling around the centre cursor. At the top of the screen, you should be able to see a dropdown menu (it's next to the 'snap' and 'proportional editing' tools). Make sure it's selected to 'bounding box centre'. I found that this worked a charm and sorted the problem right out!

(I am using Blender 2.81, so you might have a different layout.)


To clarify - in the two pictures above you originally posted 1) you have the larger circumference selected. 2) that selection is the one you are scaling 3) when you scale it down it is the second picture [the top one] and it doesn't stay centered.

Rotation and scaling are relative to the pivot point. Even if you have the cursor centered but have the pivot on something else it won't work. Both the cursor and pivot point have to be set.

There is also another slight possibility. You may have inadvertently moved the objects origin relative to the geometry while in edit mode. This shouldn't be the case here, but I will explain anyway in case it helps later with something else.

Create a cube. Notice the orange dot that floats around in its center. Go into edit mode [tab], select all vertexes and move them - the whole box will move, but the origin marker [the orange dot] stays still. Now go back to object mode. Now move the box around again. Notice the orange dot isn't in the center of the cube anymore. You have re-oriented the entire objects geometry's origin.

If you tell the cursor to go to selected, and it is trying to find the origin, it will wind up somewhere you may not intend. Reset the origin to the geometry. See image. Other then that you may wish to reset rotation and scale (CTRL-A)... ?enter image description here

  • $\begingroup$ re1) Sorry I didn't show the rest of the screen. I was thinking of optimising the image over helpfulness. My bad. Clarified that in the video.<p>re2) The whole shape is a cylinder with a bevel and a couple of loops. Earlier version of what was shown in the video. Nothing unusual about its shape. I had selected the vertices on one of the loops, which was the same size and shape as the outer diameter seen in the image. The look is not warped in any direction. It's a flat circle as it appears in the image so there is no depth in the vertices. $\endgroup$ – EkDor May 16 '19 at 0:21
  • $\begingroup$ re3) The second image (bottom one) is showing the shape before I edited it. The top is being edited showing the non centred location of the scale tool in relation to the selected vertices. $\endgroup$ – EkDor May 16 '19 at 0:24
  • $\begingroup$ As shown in the movie both the origin and cursor are not located where it is centred while scaling.The offset of the origin in the object is along the axis and appears to be in the world centre. But this should still scale correctly but shift the vertices along that axis which we shouldn't be able to see in this view. I have tried shifting both the cursor and the origin and not seeing a change. But... $\endgroup$ – EkDor May 16 '19 at 0:28
  • $\begingroup$ I have been seeing this in other objects in my scene and wasn't seeing this since I last updated 2.8. Possibly I didn't notice since I am just new to Blender (Maya is my normal stomping ground). But something I have noticed is that it seems to be related to vertice selection. Note: to be clear I have also started to see some odd things with translate in less clear scenarios; related to snapping. $\endgroup$ – EkDor May 16 '19 at 0:36
  • $\begingroup$ If I box select and try to scale and get this happen. I can deselect one of the vertices and then reselect it and it will now use that vertice as the centre. But if I don't do that the centre point is not located on any vertice nor is it centre of the selection as seen in the video. Also I have checked the state of the objects Translate, Scale, Rotation and have been cleared. Also no effects being applied to the object that might be causing vertice location confusion etc. $\endgroup$ – EkDor May 16 '19 at 0:37

Closing this: Repeating the steps I used to create the same shape did not repeat the issue seen in the same file. It did happen to some of the other objects in the scene. but It's basically unrepeatable so I'll call it as it is. I will set aside a copy of the file with that object still misbehaving for future reference or testing. Just FYI, never know. Contact me by IM if anyone wishes... Cheers and thanks for the help/discussion!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.