1
$\begingroup$

I'm fairly new to Blender, but have come from a 3DS max and Inventor background. I have imported a model done in Inventor, in OBJ format. This is quite a large model of a steel structure with approx 500 objects. On import all of the objects have their origin at the world origin (0,0,0). These objects local axis are also aligned with the world axis and not with the objects.

I can set the origin of these objects to a new location but aligning the local axis is tricky. I can create a new transform based on a face but this will mean creating lots of custom transform orientations for many parts. Is there a way of manually adjusting the local axis to align with these parts?

Below is a screenshot of part of the project. The image shows 3 tubes all at different angles. The local axis of the closest tube is not ata ll aligned with the tube part.

I would like the z-axis to align with the axis of the tube.

At the moment my work around has been to select the end face of the tubes and align the view to that face. Then add an empty aligned to view. If I parent the tube to the empty I now have the desired local axis that I can scale. It is taking a while to do these steps on many parts.

enter image description here

Thanks in advance

Nigel

$\endgroup$
  • $\begingroup$ How do you define an axis that is 'aligned" with the objects? Is there a simple unambiguous rule, or is it human judgement? If you can define some simple rules it may be possible to script this, otherwise not really. $\endgroup$ – Sazerac May 9 at 0:43
  • $\begingroup$ Maybe what I should have said was have an axis aligned with a normal of a face. I have found a work around which I have outlined below. $\endgroup$ – NigelSims May 10 at 14:44
0
$\begingroup$

At the time of import: use the FBX options, and scale to 0.005 or 0.05 Else: Make an empty, import your 500 objects. When they come to scene make sure you are looking at your empty. then "A" (to select all), then "A" (or ALT+A if 2.8) and every object is now selected. LASTLY: SELECT YOUR EMPTY. Then hit CTRL+P (Parent objects), KEEP CURRENT TRANSFORMS. Everything will be child of the empty object you made. Now, press "N" to bring the numeric panel on your 3D viewport. And try scale 0.05 on all X, Y, Z See if that works.

If you find this is the answer, thank you for your consideration to vote me as the answer by clicking to the left :the icon with a check mark and upvote this answer.

BFCT_Schiller

$\endgroup$
  • $\begingroup$ <kbd>N</kbd> for keyboard markdown. $\endgroup$ – batFINGER May 10 at 14:55
  • $\begingroup$ thanks! so <kbd>G</kbd> rateful $\endgroup$ – Pierre Schiller May 10 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.