1
$\begingroup$

The seemingly random edges that are crisscrossing everywhere do not exist and can't be clicked on. If I click on the connecting vertices, the "edge" disappears. Any fix other than just ignoring them? Applying subdivision or solidify modifiers seems to make them go away but I have to work with those off for now.

Answer: When I press "Adjust edit cage to modifier result" twice it just fixed it.

$\endgroup$
2
  • $\begingroup$ Hey, could you upload your .blend-file to blend-exchange.giantcowfilms.com? I'll have a closer look. My first guess would be duplicate vertices. try "remove doubles" in Edit mode $\endgroup$
    – bstnhnsl
    Commented May 8, 2019 at 13:37
  • $\begingroup$ @bstnhnsl It says error uploading so I'll try again in awhile. I did try removing doubles which didn't remove any. Also interestingly enough they don't show up in edge or face select, only vertex select. $\endgroup$
    – Mark Ryan
    Commented May 8, 2019 at 13:47

2 Answers 2

2
$\begingroup$

Certain problem in this case might be different but if unnecessary geometry is only composed of edges you can subtract selection based on selection modes.
Deselect all, enter Edge selection mode, select all. Then enter Face selection mode. Selection will be edited accordingly as edges can't be selected in Face selection mode. Switch to Edge selection mode, invert selection, delete edges.

enter image description here

There are other ways to delete loose geometry, one way is to use Select > Select All By Trait and use options there.

$\endgroup$
2
  • $\begingroup$ I think I followed what you said correctly but for some reason the edges only appear in vertex select mode so this doesn't work? $\endgroup$
    – Mark Ryan
    Commented May 8, 2019 at 20:15
  • 1
    $\begingroup$ @MarkRyan it is impossible to tell exactly what and why didn't work from several words description. Edges by definition can not appear only in Vertex selection mode without being selectable in Edge selection mode. You could upload the file to blend-exchange.giantcowfilms.com for more detailed diagnosis (pasteall.org if the first isn't working) or at the very least include more screenshots of what happens exactly when selecting them (file is better in this case). $\endgroup$
    – R El Clein
    Commented May 8, 2019 at 23:22
0
$\begingroup$

Remove Doubles in Edit mode should fix the issue.

Switch to Edge mode and Remove Doubles

Also switch to Vertex mode and Remove Doubles

And even Face mode

$\endgroup$
3
  • $\begingroup$ Viewing it in edge or face mode doesn't display the edges but switching back to vertex edit brings them back. $\endgroup$
    – Mark Ryan
    Commented May 8, 2019 at 13:57
  • $\begingroup$ Then you can just ignore it if its not affecting render quality $\endgroup$ Commented May 8, 2019 at 14:10
  • 3
    $\begingroup$ Why would remove doubles fix this? $\endgroup$
    – batFINGER
    Commented May 8, 2019 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .