9
$\begingroup$

On models with a lot of holes/protrusions and other details which require extra loopcuts, how can I keep those loopcuts from having a large effect on other parts of my model?

For example, I want to keep this edge smooth like it is now, but there are some unwanted subsurfing of the inner corner:

enter image description here

If I add a loopcut to fix it, it adds a bump in the nice outer curve:

enter image description here

Is there a way sharpen up the inner corner without messing up the nice outer curve?

enter image description here

I tried mean crease, but it causes a lot of distortion and too-sharp edges.

Here is the example .blend.


Another example of a similar problem:

enter image description here

$\endgroup$
6
$\begingroup$

IMHO, it is hardly possible to keep that curve exactly the same as what it is after adding support loop, unless you take GiantCowFilms' second way, though it will bring new problem for subdivision. However, you can make the difference unnoticeable:

enter image description here

You can either do this by sliding GG or ShiftV on each side; or, select both sides, then W > Smooth, tweak levels and axes in F6 panel.

$\endgroup$
1
$\begingroup$

enter image description here This one creates the extra loop cut, but adds a triangle to your mesh. Although triangles are considered bad, sometimes they are unavoidable.

enter image description here Here a slightly different example, which moves the triangle to the face on the side, making it smaller.

Both of these examples are not perfect... perfection might just be impossible in this case.

$\endgroup$
0
$\begingroup$

What I'd try is to make the loop cuts as in your second illustration (the one with the frownie face), then use Vertex slide to move the pair of vertices causing the unacceptable bump towards the middle of that segment of the mesh, until the bump disappears. This would leave the mesh with all quads.

$\endgroup$
0
$\begingroup$

You can add an edge split modifier and specify the angle for sharp edges.

If you need more control, uncheck 'Edge Angle' and check 'Sharp Edges'. Then in edit mode select the edges you want and hit Control+E and select 'Mark Sharp'.

Another option is 'Edge Crease', select the edges and hit Shift+E in edit mode. the range is -1;+1. +1 is the sharpest, 0 no changes and -1 removes Creases.

$\endgroup$
  • $\begingroup$ I'd prefer to avoid edge split, it makes edges too unnaturally sharp for my taste.. I did try mean crease, but it caused a lot of distortion in my example (as I stated in my question). $\endgroup$ – gandalf3 Jul 13 '14 at 6:36
0
$\begingroup$

How about something like this?

enter image description here

$\endgroup$
0
$\begingroup$

I added a few more divisions along the curve to bring the low poly more in line with what the subsurf is doing.

I also used Creased edges set to 0.25 along the outer perimeters.

enter image description here

enter image description here

Here's the .blend http://www.pasteall.org/blend/30407

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.