0
$\begingroup$

As an absolute beginner in Blender 2.8 I modeled a hammer.

Although the mesh looks completely OK to me, it gets ugly in a few places during rendering.

I have 2 questions: 1.) What did I do wrong? & 2.) How do I fix this?

I would be very happy about your advice.

enter image description here

enter image description here The complete Model found here: https://drive.google.com/file/d/1VAgxWriZOUKWnnxoGWMVHuRJk8Jojx9M/view?usp=drive_web

$\endgroup$
1
$\begingroup$

The mesh looks TERRIBLE, It contains so many unnecessary vertices, edges, faces. And the faces, NO.

And in the render, you turn the smooth shading on, but in your mesh, the edges, they are probably in flat shading. You don't even get enough bevel edge for the smooth shading, that's a reason for your bad rendering.

You may abused the Boolean tool and accidentally apply it to a high-res mesh. Or you just download, import the mesh from other file format.

There are two way to fix this mess:

  1. Join those unwanted topologies manually
  2. Remesh it by some tool and decimate to a reasonable resolution. (Instant Meshes might be a powerful one)

But the mesh it self isn't that complicated to craft, you might want (and need) to start it over again, with some good topologies.

Here is a good tutorial for this task: Blender Guru - Anvil

$\endgroup$
  • 1
    $\begingroup$ Unfortunately, I don't really understand your explanation. But what I mean to have understood is that I should probably still bevel the corners. I will try it out right now. I can understand that I have too many surfaces in other areas, but that is not the subject of my question here. $\endgroup$ – Ralf Dietrich May 7 at 11:49
  • $\begingroup$ The faces in what you considered is ugly while rendered, is not support by 3 or 4 vertices, but 10. In Blender, it call N-gons, which is a very itchy problem in render shader. It could be OK in flat shading, but when calculate it as smooth, it just wont work as we thought it could be. $\endgroup$ – Hikariztw May 7 at 11:56
  • $\begingroup$ I realize I'm still a little overwhelmed. I'll do the Anvil tutorial you suggested, and I'll get back to the hammer when I've learned more. First of all thank you for your help $\endgroup$ – Ralf Dietrich May 7 at 12:03
  • $\begingroup$ You can use subdivide modifier to test whether your mesh is in good topologies. If the result seem to be weird in some certain places, than you should look around that area to fixed the problem. $\endgroup$ – Hikariztw May 8 at 4:48
1
$\begingroup$

By default Blender tries to smooth all edges, even if they are 90deg. So, you need to tell Blender, do not smooth sharp edges. To do this, you need to go in mesh data settings and check autosmoth in normals section

enter image description here

$\endgroup$
  • $\begingroup$ Tx. This is contructive answer that helps. :-) $\endgroup$ – Ralf Dietrich Jun 12 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.