1
$\begingroup$

I have the following Blender structure:

enter image description here

When I export it as an obj with default export settings, I see the following if I import it for example into Unity:

enter image description here

As one can see, Blender merges the 4 objects into a single one. However, I don't want that.

I have tried changing the export settings, but none of my approaches kept the objects separate.

Can somebody explain why Blender merges my objects and how I could keep them separate (as children of a main object)?

This is what I tried and what didn't work:

enter image description here

$\endgroup$
2
$\begingroup$

I got it.

I unticked "Objects as OBJ Objects", and I unticked "Objects as OBJ Groups". Also, I ticked "Write Materials" and "Write Material Groups".

Here is a screenshot of the entire settings:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.