0
$\begingroup$

I don't have experience with addons but it should work when I download the .zip from github and install it over the preference window. I want to keep using Blender 2.8 for modelling but the error states that I get when trying to active the module:

There is a Python version mismatch.

The module is called Animation Nodes and is compiled for Python ver. 3.5.3 yet Blender 2.8 uses Python ver. 3.7.0. What can I do to use it because Blender 2.79 doesn't work with the addon if I remember correctly. Also I want to keep working with 2.8.

Thanks in advance!

$\endgroup$
0
$\begingroup$

No, you need to wait until someone upgrade it.

Since Blender 2.8 change a lot of code APIs (and Python to 3.7.0), it is currently not possible to use the add-on directly if the code is not upgrade to 2.8 APIs.

It might be possible to upgrade the script by your self, but for those complicated scripts like Animation Node, there will be a lot of thing need to fix.

Here is a discussion: Updating Built In Addons to Blender 2.8, and some one even maintain an APIs change list under the discussion.

$\endgroup$
  • $\begingroup$ Thank you for your help on this. I noticed that he specially compiled the addon for 2.8 in a different repository. Otherwise updating it manually myself would have been the only other option. Thanks again, this issue has been resolved. $\endgroup$ – Tyron May 7 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.