1
$\begingroup$

I am trying to unwrap the UVs on this object and have marked the seems so there should be 4 islands, however once I click the "unwrap" button Blender seems to make several extra islands, some of which are only one face. I have checked to make sure there is no non-manifold geometry and there is none.

If it matters, I have been 3D modelling for a few years but have only recently picked up Blender. I am more used to unwrapping in Maya but would like to learn Blender. I have tried googling for this issue and have only found tutorials on UV unwrapping, none of which address this specific issue.

Attached is a picture of the model with transparency on so you can see the marked seems, and then a picture of the UVs made after clicking unwrap, I spread them out a bit just so you can see how many small ones there are. enter image description here enter image description here

Thanks in advance.

$\endgroup$
  • $\begingroup$ It's possible that the UV 'islands' are not completely separated. If you select one face on a particular 'island' you want to unwrap, press Ctrl+L to select all linked faces, and make sure you delimit by Seam (the options panel for "Select Linked" is near the bottom left), see how much of the mesh is selected. $\endgroup$ – adroitwhiz May 6 at 7:24
1
$\begingroup$

It isn't that you have non-manifold geometry, it is that the UV seams "cut" the mesh into pieces.

You need to find the separated faces on the mesh and remove the seam from one of the edges so it stays connected.

With both the UV/Image editor and 3D view visible, enable the sync selection option so that the two editors use matching selections. Then Select the UV islands so you can see them on your model and clear some seams to keep them connected to the rest of the mesh.

selection sync option

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.