0
$\begingroup$

Recently I started texturing parts of my model and came across a problem I cannot figure out a solution.

I unwrapped the model as I liked and created a simple transparency map to not use any modifiers to cut out windows and so. As soon as I connected the map to see the first result the texture was slightly off on the 3d model. I looked in the UV-Editor but there the mesh is correctly unwrapped as it should be, however on the 3d model it is not. Do you have some advice for me or a solution?

Here the result

The same problem here.

The entire model so far.

In the last picture, you can see it's not only a problem at the rear door but also with the sunglass-look at the cockpit windows.

Here is the link

Do you have some advice for me or a solution?

$\endgroup$
  • $\begingroup$ You can always upload your file to blend-exchange, if you want to take us a look at it. If you decide to do so, make sure to pack external sources ("File - External Data - Pack all into .blend") $\endgroup$ – metaphor_set May 5 at 15:16
  • $\begingroup$ @metaphor_set I added the link you may have a look at it. The file exceeds the 30 MB limit by 3 MB so you'll find on the google drive. $\endgroup$ – OupsyDoupsy May 5 at 16:44
0
$\begingroup$

Not allowed to comment yet. Just a hunch, but do you have a not-unwrapped duplicate of this plane that is rendering on top your unwrapped plane by accident? This is what it looks like from your screenshot and I've made the same mistake.

Turn off the renderable option in the outliner for anything you don't want to render.

EDIT: If that is not the problem, overlay the texture on your UV editor and make sure your UVs line up with the texture itself.

GOT IT: Problem is that the scale of your X axis in your shader's mapping node is set to 1.100 instead of 1.000. Fix that and it renders like this:

enter image description here

$\endgroup$
  • $\begingroup$ I don't understand your EDIT quite well as I started with this project to texture my objects instead of using procedural materials and other ressources $\endgroup$ – OupsyDoupsy May 5 at 16:45
  • $\begingroup$ I found your problem: The x-scaling of your mapping node is set to 1.100 instead of 1.000. Change that and it tiles correctly. I rendered it and it looks better. $\endgroup$ – hatinacat2000 May 5 at 17:02
0
$\begingroup$

Your UV's are mapped correctly, but in your shader you mess with the mapping. 9 times out of ten, if you have custom non-procedural UV's, you don't really need to mess with them after the fact. Directly mapping your UV's to your texture seems to work.

The model with the sunblock style cockpit lining

Quick aside: make sure to hit "shade smooth" in the Object menu before you call this model done, otherwise it will look scaly.

$\endgroup$
0
$\begingroup$

your problem is in your shader settings, for the mapping node you are refrencing to use the uv's of the object but its set to a scale of 1.1 which is pushing everthing of a little change this to 1 and it will be fine, scale is currently set to 1.100 instead of 1.000 Change that and its good.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.