0
$\begingroup$

This might be a bug, and I've spent all night hunting it. I think my solution will have to be rebuilding some of my file and animation, but I was wondering if anyone had run into this problem:

I have a basic walk-cycle for a character for a unity project, along with 3 shape keys. The last shape key is a king of growl/grimace. In blender everything is fine, the walkcycle "walks", the shape keys shape, all is good. In Unity the character comes in with only the first 2 shape keys, and the last "growl" shape key as part of the mesh.

Interestingly, Unity wouldn't let me import this as a .blend file.

So, I start deleting bits and pieces (the shape keys and the animations) and finally ended up with a FBX file with a new 3rd shape key and a new animation, with a normal face. I tried to recreate this with no animations (to start fresh animating in Unity), and all my imports still had the "growl" shape key as part of the mesh (and yes, this is well after I've deleted the offending shape key).

Here's where it gets weird! Back in Blender: When I added a shape key, and brought my new shape key from 0.0 to 1.0, the growl came back as if I sculpted it. There was already information in the shape keys when I added them. I added another 3, the growl was in all of them.

So, I thought this was Unity messing up, but somewhere in Blender, after shape keys were removed and animations were cleared, the memory of that "growl" shape key still exists, and I can't get it out. AND... all the FBXs files I export from there have the growl.

Any ideas how this is happening? Is it some kind of buffer? Can I clear it out?

$\endgroup$
  • $\begingroup$ Have a look in the Dope sheet, see if therre's a hang-over strip called "Key" for the object. I've encountered this problem several times and it can be eradicated by deleting this strip as well as the shapekey itself. You may have to save the file, exit Blender and reload it. $\endgroup$ – Edgel3D May 5 at 13:26
  • $\begingroup$ You could always use the built-in tools to upload images or upload your file to blend-exchange, if you want to take us a look at it. $\endgroup$ – metaphor_set May 5 at 14:54
  • $\begingroup$ I'm getting an error uploading. The whole file is having issues now. I looked for the Key strip in the Dope Sheet and didn't find one. Luckily, there were a lot of animations I have to do, and I need to add some components, so the loss of one walk cycle is not the end of the world. Thanks for your advice, I'll keep a look out for that as a solution if this happens again. My theory is I was sloppy with the keyframe recorder, and left it on while I was adjusting or making a shape key. $\endgroup$ – William Williams May 5 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.