2
$\begingroup$

I’ve created a low-poly stylized tree in Blender 2.8 and rendered it with Eevee. Some of the shadows on the leaves are very jagged and quite ugly.

The entire scene is simply a camera, a sun light source and a few meshes with a single material each for the tree.

enter image description here

enter image description here

enter image description here

I’ve played a little with the sun light settings but it only seemed to shift where the jaggedness was occurring. I've taken a look at some similar threads on StackExchange but the suggestions didn't seem to help.

Here is the .blend file

Ideally, I’m not simply chasing a “how to fix it”. I don’t have much knowledge on 3D modelling and rendering, so any explanations as to why this is occurring would be great!

$\endgroup$
2
$\begingroup$

This is caused by the inaccurate behavior of Shadow Mapping used in real time rendering enginnes like EEVEE and almost all game rendering engines. People call them Shadow Acne.

What you see is actually pixelated shadow mapping to some boundary area, causing those alias shadow show on the mesh.

There are many solutions to overcome this problem, but since performance is the main issue in real-time rendering, the best solution changes depend on the situation of your application.

You can check out this explanation about shadow mapping: Shadow Mapping - LearnOpenGL


Blender 2.81 Update Information

According to the latest Blender,

Soft shadows were changed and now enabled with the Use Soft Shadow option in the render properties Shadow panel. This will progressive smooth shadows, in combination with a more conventional shadow filtering method (PCF). Exponential and Variance Shadow Mapping methods were removed. (d8aaf25c23fa)

The way EEVEE render shadow has been changed to a more common method. And the problem of Shadow Acne should be reduce or even solved. Check for the latest Blender to see whether the shadow has been fixed.

$\endgroup$
  • $\begingroup$ As a follow up question, lets say I was wanting it to look like these low-poly trees: 3dwarehouse.sketchup.com/warehouse/v1.0/publiccontent/… How would you go about fixing the issue i'm describing? As an aside, i've been interested in learning OpenGL (and graphics programming in general) for a while. Have you found it helps you in your 3D modelling? $\endgroup$ – daviegravee May 5 at 7:00
  • $\begingroup$ @daviegravee You could change the light properties under your light sources, which might fix some problem. And under the render properties > Shadows, you might use higher Size depend on your light type, soft shadow might work as well. And for learning computer graphic, yes it help a lot, you can get more clear about what can be achieved in general method, making your modeling pipeline more robust. $\endgroup$ – Hikariztw May 5 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.