0
$\begingroup$

I've just started playing with the add-on and created some simple tree to generate tiles but the it works very slow. Currently I have weak machine and the procedure may not be super optima but even very little amount of geometry (700 verts) take ~1.5 s to generate. I don't know if I did something wrong or the add-on it not optimized yet.

enter image description here

$\endgroup$
1
$\begingroup$

The slow performance is most likely due to your unorganized and unoptimized node tree. In order to identify the source of the regression, we can measure the execution time of each of the individual nodes and identify the node(s) that takes the most time and try to refactor them. This measuring can be activates by pressing the details button here:

Node Tree

In your node tree, my best guess is, your Plane subprogram always generates the same mesh, yet you compute the mesh at every iteration! So simply move the node generating the plane outside of the loop and pass it as a parameter. Moreover, don't reinvent the wheel, use the Grid Mesh node instead. Also, remove all those viewer nodes, they have some impact on performance.

$\endgroup$
  • $\begingroup$ I didn't know the viewer were executed, what is the little pause icon for? I've tried to turn on Cache on "Plane" invocation but result is that nothing shows up. Also each output mesh is than transformed so is it possible for single mesh to be transformed into multiple locations? $\endgroup$ – Paweł Audionysos May 3 '19 at 21:50
  • $\begingroup$ The Grid Mesh is not doing the same thing. I have each plane separated with some gap between them $\endgroup$ – Paweł Audionysos May 3 '19 at 21:55
  • $\begingroup$ The "Create Polygon Indices List" eats 1.57 s out of 1.61 s right now is it normal? $\endgroup$ – Paweł Audionysos May 3 '19 at 21:59
  • $\begingroup$ I'm sorry I've had the viewer under this node an it was it. I removed all the viewers and the same generation takes ~16 ms :) $\endgroup$ – Paweł Audionysos May 3 '19 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.